Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
10 авг 2022, 23:34

Наименование переименовать

Автор Samouchka, 06 дек 2017, 18:51

0 Пользователей и 1 гость просматривают эту тему.

Samouchka

Здравствуйте. Платформа 8.3 Обычная форма.Есть справочник Номенклатура, у которого стандартный реквизит называется Краткое наименование; и есть реквизит Полное наименование. Нужно их поменять местами. То есть, чтобы полное наименование сделать как краткое наименование во всей номенклатуре. Подскажите, пожалуйста, как такое сделать?

Golickoff

Выборка = Справочники.Номенклатура.Выбрать();
Пока Выборка.Следующий() Цикл
    НомОбъект = Выборка.Ссылка.ПолучитьОбъект();
    КраткоеНаименование = НомОбъект.КраткоеНаименование;
    НомОбъект.КраткоеНаименование = НомОбъект.ПолноеНаименование;
    НомОбъект.ПолноеНаименование = КраткоеНаименование;
    НомОбъект.Записать();
КонецЦикла;
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Samouchka

Цитата: Golickoff от 07 дек 2017, 02:33
Выборка = Справочники.Номенклатура.Выбрать();
Пока Выборка.Следующий() Цикл
    НомОбъект = Выборка.Ссылка.ПолучитьОбъект();
    КраткоеНаименование = НомОбъект.КраткоеНаименование;
    НомОбъект.КраткоеНаименование = НомОбъект.ПолноеНаименование;
    НомОбъект.ПолноеНаименование = КраткоеНаименование;
    НомОбъект.Записать();
КонецЦикла;


А это во внешней обработке писать?

Golickoff

Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Samouchka

Выдает ошибку

{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(31)}: Ошибка при установке значения атрибута контекста (НаименованиеПолное)
    НомОбъект.НаименованиеПолное = НомОбъект.Наименование;
по причине:
Реквизит недоступен для группы

ilyay

В свойствах реквизита поправьте, что реквизит доступен не у элемента, а у элемента и группы

Samouchka

Цитата: ilyay от 07 дек 2017, 11:19
В свойствах реквизита поправьте, что реквизит доступен не у элемента, а у элемента и группы

Конфигурация типовая под замком. не исправляется

ilyay

Тогда проверяйте ЭтоГруппа = Ложь

Samouchka

Выборка = Справочники.Номенклатура.Выбрать();
Пока Выборка.Следующий() Цикл

    НомОбъект = Выборка.Ссылка.ПолучитьОбъект();
Если Не НомОбъект.ЭтоГруппа Тогда

    Наименование = НомОбъект.Наименование;
    НомОбъект.Наименование = НомОбъект.НаименованиеПолное;   
    НомОбъект.НаименованиеПолное = Наименование;
    НомОбъект.Записать();
КонецЕсли;


Вот. Все заработало. Спасибо всем за помощь!

Samouchka

Подскажите, пожалуйста, решение вот такой задачи.Надо Наименование приравнять к полному наименованию и чтобы было видно как это происходит. Посоветовали использовать метод Состояние.

Выборка = Справочники.Номенклатура.Выбрать();
Счетчик = 0;
Пока Выборка.Следующий() Цикл   
Счетчик = Счетчик + 1;
НомОбъект = Выборка.Ссылка.ПолучитьОбъект();
Если Не НомОбъект.ЭтоГруппа Тогда
НомОбъект.Наименование = НомОбъект.НаименованиеПолное;       
НомОбъект.Записать();
Состояние(Счетчик);
КонецЕсли;
КонецЦикла;

Наименование приравнялось к полному наименование, но состояния не видать. Подскажите, где ошибка.

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск