Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 12:43

помогите с отчетом

Автор llpass, 02 дек 2017, 17:02

0 Пользователей и 1 гость просматривают эту тему.

llpass

В списке контраагентов есть кнопка взаимозачеты с вызовом модально отчета ВедомостьПоКонтрагентам

как передать сброс в ТаблицуМФ чтоб снялись все галки которые остаются после использования непосредсвенно самого отчета....  помогите плиз....   


Процедура ПоКнопкеВзаиморасчеты()
   
   Если ПустоеЗначение(ТекущийЭлемент()) = 1 Тогда
      Предупреждение("Не выбран контрагент", 60);
      Возврат;
   ИначеЕсли ТекущийЭлемент().ЭтоГруппа() = 1 Тогда
      Предупреждение("В отчет можно вывести только Контргента!", 60);
      Возврат;
   Иначе
      
      Группировки = СоздатьОбъект("СписокЗначений");
      
      Группировки.ДобавитьЗначение("Фирма",        "Фирма");
      Группировки.ДобавитьЗначение("Контрагент",   "Контрагент");
      Группировки.ДобавитьЗначение("СвойствоКонтр","Свойство контрагента");
      Группировки.ДобавитьЗначение("Договор",      "Договор");
      Группировки.ДобавитьЗначение("ВидДолга",     "Вид долга (бух. счет)");                   
      Группировки.ДобавитьЗначение("СтавкаНП",     "Ставка НП");
      Группировки.ДобавитьЗначение("КредДокумент", "Кредитный документ");
      Группировки.ДобавитьЗначение("Документ",     "Документы движения");
      
      Группировки.Пометка(1, 1);
      Группировки.Пометка(4, 1);
      Группировки.Пометка(8, 1);
                               
      Расшифровка = СоздатьОбъект("СписокЗначений");
      Расшифровка.Установить("Отчет", "ВедомостьПоКонтрагентам");
      
      // все настройки помещаем в список
      ВыбДатаКонца  = Мин(РабочаяДата(),ПолучитьДатуТА());
      ВыбДатаНачала = СокрЛП ("01.11.2007");
      
      Расшифровка.Установить("ДатаНачала",       ВыбДатаНачала);
      Расшифровка.Установить("ДатаКонца",        ВыбДатаКонца);
      Расшифровка.Установить("ВыбРазделитель1",             "");
      Расшифровка.Установить("ВыбРазделитель2",             "");
      Расшифровка.Установить("ВыбРазделитель3",             "");
      Расшифровка.Установить("ВидРазделителя",               1);
      Расшифровка.Установить("ВыбКонтрагент", ТекущийЭлемент());
      Расшифровка.Установить("ВыбДоговор",                  "");
      Расшифровка.Установить("Долги",                         1);
      Расшифровка.Установить("ПоОперациям",                   0);
       Расшифровка.Установить("ВыбВидВалюты",                   1);
      Расшифровка.Установить("СписокВидовОтчетов",           3);
      Расшифровка.Установить("Группировки",        Группировки);
      
      глОбработкаРасшифровки(Расшифровка,"","");
      
   КонецЕсли;
КонецПроцедуры // ПоКнопкеВзаиморасчеты()


llpass

понятно.... помощи нет на  этом сайте

alexandr_ll

Цитата: llpass от 04 дек 2017, 20:43
понятно.... помощи нет на  этом сайте
Вы объясните толком, чего вы хотите?
Что именно вы хотите очищать?
При использовании отчета "Взаиморасчеты" из справочника "Контрагенты" таблица множественного фильтра не заполняется, и очищать ее нет необходимости. Если у вас сохраняются настройки отчета при повторном использовании отчета, проверьте, возможно в самом отчете включено "Сохранять автоматически" в сохранении настройки

llpass

Цитата: alexandr_ll от 05 дек 2017, 06:42
Цитата: llpass от 04 дек 2017, 20:43
понятно.... помощи нет на  этом сайте
Вы объясните толком, чего вы хотите?
Что именно вы хотите очищать?
При использовании отчета "Взаиморасчеты" из справочника "Контрагенты" таблица множественного фильтра не заполняется, и очищать ее нет необходимости. Если у вас сохраняются настройки отчета при повторном использовании отчета, проверьте, возможно в самом отчете включено "Сохранять автоматически" в сохранении настройки

мне не нужно очищать!!

в самом отчете есть автоматическое сохранение настроек и оно нужно , и нужно сделать так чтоб галки там снимались
но только при модальном вызове отчета.... если есть возможность изменять настройку группировки модально,  не трогая  настройки самого отчета, разве нет возможности также выбирать настройки табличного фильтра?       


alexandr_ll

Цитата: llpass от 05 дек 2017, 13:56
Цитата: alexandr_ll от 05 дек 2017, 06:42
Цитата: llpass от 04 дек 2017, 20:43
понятно.... помощи нет на  этом сайте
Вы объясните толком, чего вы хотите?
Что именно вы хотите очищать?
При использовании отчета "Взаиморасчеты" из справочника "Контрагенты" таблица множественного фильтра не заполняется, и очищать ее нет необходимости. Если у вас сохраняются настройки отчета при повторном использовании отчета, проверьте, возможно в самом отчете включено "Сохранять автоматически" в сохранении настройки

мне не нужно очищать!!

в самом отчете есть автоматическое сохранение настроек и оно нужно , и нужно сделать так чтоб галки там снимались
но только при модальном вызове отчета.... если есть возможность изменять настройку группировки модально,  не трогая  настройки самого отчета, разве нет возможности также выбирать настройки табличного фильтра?     
В отчете Ведомость по контрагентам в процедуре ПриОткрытии() есть команда
Если ТипЗначенияСтр(глРасшифровка.Получить("ТаблицаМФ"))="ТаблицаЗначений" Тогда
ТаблицаМФ.Загрузить(глРасшифровка.Получить("ТаблицаМФ"));
КонецЕсли;

Следовательно для вашей задачи в модуле формы списка справочника Контрагенты в процедуре ПоКнопкеВзаиморасчеты() следует добавить в список настроек и нужный формат ТаблицыМФ
    Расшифровка.Установить("ТаблицаМФ", ТаблицаМФ);       

llpass

ТаблицуМФ уже делал как добраться до галок в строке

вика12345

При использовании отчета "Взаиморасчеты" из справочника "Контрагенты" таблица множественного фильтра не заполняется

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск