Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 12:54

Вывод в табличную часть данных

Автор Mitka90, 29 ноя 2017, 09:43

0 Пользователей и 1 гость просматривают эту тему.

Mitka90

Доброго времени суток, уважаемые!
Нужно вывести данные из справочника "Материалы" в табличную часть "Материалы" документа "Начисления ВДГО" по нажатию кнопки "Подбор", но при попытке добавить данные появляется ошибка вида:
{Документ.НачисленияВДГО.Форма.ФормаДокумента.Форма(1637)}: Метод объекта не обнаружен (ДобавитьСтроку)
        материалы.ДобавитьСтроку();


Вот сама процедура:

Процедура МатериалыОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)

Сообщить(ВыбранноеЗначение);
//  Для СчетчикЦикла = 0 по ВыбранноеЗначение.ВГраница() цикл
// НоваяСтрока = Материалы.Добавить();
// НоваяСтрока.Материал = ВыбранноеЗначение[СчетчикЦикла];
//КонецЦикла;

Для Каждого Элемен из Материалы Цикл
       
        Если Элемен.Материал=ВыбранноеЗначение Тогда
        Элемен.Количество=Элемен.Количество+1  Иначе
        КонецЕсли       
    КонецЦикла;
        Элемент=0;       
     Для Каждого Элемен из Материалы Цикл   
        Если Элемен.Материал = ВыбранноеЗначение Тогда Элемент=Элемент+1
        КонецЕсли   
        КонецЦикла;
       Если Элемент=0  Тогда
        материалы.ДобавитьСтроку();
        материалы.ТекущиеДанные.материал=ВыбранноеЗначение;
        КонецЕсли
   
     
КонецПроцедуры


Подскажите, в чём может быть проблема? Заранее спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск