Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 13:25

Как получить количество дней ежегодного отпуска?

Автор vovkalenka, 27 ноя 2017, 09:38

0 Пользователей и 1 гость просматривают эту тему.

vovkalenka

Всем привет!
Нужно вывести количество дней ежегодного отпуска, на которые имеет право сотрудник. Например, 28 или 56.
Эти дни вроде бы хранятся в табличной части таких документов, как приём на работу, кадровый перевод, начальная штатная расстановка.
А есть ли способ получения этого числа дней положенного отпуска функцией, ну или в запросе, не перебирая всех документов?

vovkalenka

Нашли функцию из базовых форм, сделали так:
ПоложеноДнейОсновногоОтпуска = 0;
ПоложеноДнейДополнительногоОтпуска = 0;
Для Каждого СтрокаОтпуска Из ОстаткиОтпусков.ЕжегодныеОтпускаСотрудника(Сотрудник,ТекущаяДата(),1) Цикл
Если Лев(СтрокаОтпуска.ВидЕжегодногоОтпуска, 3) = "Осн" Тогда ПоложеноДнейОсновногоОтпуска = ПоложеноДнейОсновногоОтпуска + СтрокаОтпуска.КоличествоДнейВГод; КонецЕсли;
Если Лев(СтрокаОтпуска.ВидЕжегодногоОтпуска, 3) = "Доп" Тогда ПоложеноДнейДополнительногоОтпуска = ПоложеноДнейДополнительногоОтпуска + СтрокаОтпуска.КоличествоДнейВГод; КонецЕсли
КонецЦикла;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск