Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 09:52

Заполнение продаж из DBF. БП 3.0

Автор Mikle, 27 ноя 2017, 08:38

0 Пользователей и 1 гость просматривают эту тему.

Mikle

Заполнить данные продаж в 1С:Бухгалтерия из файла .dbf
Файл открываю через внешнюю обработку
Процедура ПолучитьДанные() экспорт

Таблица = Новый Xbase("C:\001_139.dbf");
Таблица.Кодировка = КодировкаXBase.OEM;
ТаблицаДанных = Новый ТаблицаЗначений;

Для Каждого Поле из Таблица.поля Цикл
ТаблицаДанных.Колонки.Добавить(Поле.Имя);
КонецЦикла;

Таблица.Первая();
Пока не Таблица.ВКонце() Цикл

   Строка = ТаблицаДанных.Добавить();
   Для Каждого Поле из Таблица.поля Цикл
Строка[Поле.Имя]=Таблица[Поле.Имя];
КонецЦикла;

Таблица.Следующая();

КонецЦикла;

    Таблица.ЗакрытьФайл();

КонецПроцедуры


alexandr_ll


Mikle

Как заполнить данные продаж в 1С:Бухгалтерия из файла .dbf

alexandr_ll

Цитата: Mikle от 27 ноя 2017, 14:35
Как заполнить данные продаж в 1С:Бухгалтерия из файла .dbf
Считываешь данные из файла dbf
Создаешь временную таблицу с реквизитами нужной табличной части документа
Заполняешь таблицу данными из файла
Загружаешь временную таблицу в табличную часть
Добавлено: 27 ноя 2017, 14:48


Цитата: Mikle от 27 ноя 2017, 14:35
Как заполнить данные продаж в 1С:Бухгалтерия из файла .dbf
Можно посмотреть здесь
http://programmist1s.ru/zagruzka-nomenklaturyi-v-1s-8-3-iz-excel-ili-dbf/
обработку взять здесь
https://cloud.mail.ru/public/6Y1j/LecW9xEHh

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск