Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 12:32

Заполнение табличной части

Автор Дмитрий Ефимов, 26 ноя 2017, 19:59

0 Пользователей и 1 гость просматривают эту тему.

Дмитрий Ефимов

Здравствуйте. 1С 8.3. Справочник Номенклатура с реквизитами Марка (строка), Наименование (стандартные реквизиты).
Документ ПриходныйДокумент с табличной частью (ТабличнаяЧасть1), в которой поле Наименование (СправочникСсылка.Номенклатура) и поле Марка (строка). Необходимо что бы при заполнении Наименование подставлялось значение Марка из справочника. Прошу не судить строго за дилетантство, на форме ПриходныйДокумент при изменении Наименование создал
&НаКлиенте
Процедура ТабличнаяЧасть1НаименованиеПриИзменении(Элемент)
   Стр = Элементы.ТабличнаяЧасть1.ТекущиеДанные;
   Стр.Марка = ФормированиеДокумента(Стр.Марка);
   КонецПроцедуры

&НаСервереБезКонтекста
Функция ФормированиеДокумента(Наименование)
    Запрос = Новый Запрос("ВЫБРАТЬ
        |   Номенклатура.Марка
        |ИЗ
        |   Справочник.Номенклатура КАК Номенклатура
        |ГДЕ
        |   Номенклатура.Ссылка = &Наименование");
    Запрос.УстановитьПараметр("Наименование",Наименование);
    Выборка = Запрос.Выполнить().Выбрать();
    Выборка.Следующий();
   
   
КонецФункции
Но Марка остается пустой. Уважаемые гуру, знатоки и профессионалы подскажите, что новичке делает не так???

Oldman06

&НаКлиенте
Процедура ТабличнаяЧасть1НаименованиеПриИзменении(Элемент)
    Стр = Элементы.ТабличнаяЧасть1.ТекущиеДанные;
    Стр.Марка = ФормированиеДокумента(Стр.Наименование);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ФормированиеДокумента(Наименование)
    Запрос = Новый Запрос("ВЫБРАТЬ
        |   Номенклатура.Марка
        |ИЗ
        |   Справочник.Номенклатура КАК Номенклатура
        |ГДЕ
        |   Номенклатура.Ссылка = &Наименование");
    Запрос.УстановитьПараметр("Наименование",Наименование);
    Выборка = Запрос.Выполнить().Выбрать();
    Выборка.Следующий();
   
    Возврат Выборка.Марка;

КонецФункции

Дмитрий Ефимов

От души спасибо ВЕЛИКИЙ ГУРУ!!!
Добавлено: 29 ноя 2017, 15:01


Осмелюсь задать еще один вопрос. Если в этом же документе, но "марка" не строка, а ссылка на одноименный справочник или перечисление?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск