Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
10 авг 2022, 22:39

ПолучитьМакет не работает

Автор PeNgViN213, 25 ноя 2017, 16:52

0 Пользователей и 1 гость просматривают эту тему.

PeNgViN213

Здравствуйте, помогите пожалуйста, почему происходит ошибка в чем не точность?

Заранее спасибо

MuI_I_Ika

Потому что такие вещи можно проделывать только на сервере

PeNgViN213

Цитата: MuI_I_Ika от 25 ноя 2017, 22:15
Потому что такие вещи можно проделывать только на сервере
мне вообще убрать "на клиенте"?

MuI_I_Ika

Желательно все сделать на сервере кроме последней строчки

PeNgViN213

Цитата: MuI_I_Ika от 26 ноя 2017, 08:49
Желательно все сделать на сервере кроме последней строчки
Все равно ошибка повторяется

MuI_I_Ika

Ну судя по всему вы вообще не в форме вызываете данную процедуру, а в модуле команды.

PeNgViN213

Цитата: MuI_I_Ika от 26 ноя 2017, 12:26
Ну судя по всему вы вообще не в форме вызываете данную процедуру, а в модуле команды.
Помогите пожалуйста написать правильно код, я не совсем понимаю как нужно сделать. Я совершенно не давно изучаю 1с

MuI_I_Ika

Весь это код переносите на форму. Создаете там команду. Выводите ее в виде кнопки на форму.

Модуль:

&НаКлиенте
Процедура ОбработкаКоманды()

    ТабДок = Неопределено;
    ОбработкаКомандыСервер(ТабДок);
    ТабДок.Показать();

КонецПроцедуры

&НаСервере
Процедура ОбработкаКомандыСервер(ТабДок)

   ОбработкаОбъект = РеквизитФормыВЗначение(Объект);
   Макет = ОбработкаОбъект.ПолучитьМакет("Печать");

   ТабДок = Новый ТабличныйДокумент;
   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   ТабДок.Вывести(ОбластьЗаголовок);

КонецПроцедуры

PeNgViN213

Цитата: MuI_I_Ika от 27 ноя 2017, 12:19
Весь это код переносите на форму. Создаете там команду. Выводите ее в виде кнопки на форму.

Модуль:

&НаКлиенте
Процедура ОбработкаКоманды()

    ТабДок = Неопределено;
    ОбработкаКомандыСервер(ТабДок);
    ТабДок.Показать();

КонецПроцедуры

&НаСервере
Процедура ОбработкаКомандыСервер(ТабДок)

   ОбработкаОбъект = РеквизитФормыВЗначение(Объект);
   Макет = ОбработкаОбъект.ПолучитьМакет("Печать");

   ТабДок = Новый ТабличныйДокумент;
   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   ТабДок.Вывести(ОбластьЗаголовок);

КонецПроцедуры


Так я понял, еще вопросик в макете есть <текст[НомерДокумента]текст>, пытаюсь указать Макет.Параметры.НомерДокумента = Номер; - не работает, переменная не определенна Номер

MuI_I_Ika

Судя по ошибке ругается на номер. Значит вы его никак не задали. Если вызов идет из формы дкоумента, тогда Объект.Номер

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск