Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 авг 2022, 10:28

НДС по умолчанию в форме на конкретную организацию

Автор vitali279, 23 ноя 2017, 12:40

0 Пользователей и 1 гость просматривают эту тему.

vitali279

Здравствуйте, есть процедура которая в форме выставляет по умолчанию 18% НДС
Процедура ФинансовыйРезультатПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
   Организация.Наименование = ДокументОбъект.Организация;
   Если НоваяСтрока И Не Копирование  Тогда
      Элемент.ТекущиеДанные.СтавкаНДС = Перечисления.СтавкиНДС.НДС18;
       КонецЕсли;
КонецПроцедуры

Но в таком случае на любую организацию, которую выберешь в этой форме НДС проставится, а нужно чтобы ставился
только на определенную ???


Golickoff

Если НоваяСтрока И Не Копирование И ДокументОбъект.Организация = Справочники.Организации.НайтиПоКоду(КодНужнойОрганизации) Тогда
    Элемент.ТекущиеДанные.СтавкаНДС = Перечисления.СтавкиНДС.НДС18;
КонецЕсли;

или
Если НоваяСтрока И Не Копирование И ДокументОбъект.Организация = Справочники.Организации.НайтиПоНаименованию(НаименованиеНужнойОрганизации) Тогда
    Элемент.ТекущиеДанные.СтавкаНДС = Перечисления.СтавкиНДС.НДС18;
КонецЕсли;

но это не круто. Лучше так
Если НоваяСтрока И Не Копирование И ДокументОбъект.Организация = Справочники.Организации.НайтиПоРеквизиту("ИНН", ИНННужнойОрганизации) Тогда
    Элемент.ТекущиеДанные.СтавкаНДС = Перечисления.СтавкиНДС.НДС18;
КонецЕсли;

А я бы сделал так
Если ДокументОбъект.Организация = Справочники.Организации.ПолучитьСсылку(Новый УникальныйИдентификатор(GUIDНужнойОрганизации)) И НоваяСтрока И Не Копирование Тогда
    Элемент.ТекущиеДанные.СтавкаНДС = Перечисления.СтавкиНДС.НДС18;
КонецЕсли;
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск