Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 03:22

перебор всех параметров элемента справочника в цикле

Автор andron81_81, 23 ноя 2017, 09:05

0 Пользователей и 1 гость просматривают эту тему.

andron81_81

Доброе утро всем.
Вот такая проблема

можно ли каким-то образом в цикле перебрать все параметры элемента справочника. скажем есть некий справочник .
Каждый элемент имеет набор параметров (Параметр1,..., ПараметрN). Требуется вывести (при помощи "Сообщить") скажем для элемента справочника 00000001 в цикле так :

Параметр1              значение1
Параметр2              значение2
Параметр3              значение3
Параметр4              значение4
Параметр5              значение5
.......
ПараметрN              значениеN

просто статически их выводить не выход. их много.

Golickoff

Реквизиты = Метеданные.Справочники.НекийСправочник.Реквизиты;
Для Каждого Реквизит Из Реквизиты Цикл
    Сообщить(Реквизит.Синоним + "    " + НекийСправочникСсылка[Реквизит.Имя]);
КонецЦикла;
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

andron81_81

Цитата: Golickoff от 23 ноя 2017, 09:22
Реквизиты = Метеданные.Справочники.НекийСправочник.Реквизиты;
Для Каждого Реквизит Из Реквизиты Цикл
    Сообщить(Реквизит.Синоним + "    " + НекийСправочникСсылка[Реквизит.Имя]);
КонецЦикла;


круто. спасибо. попробую

Golickoff

Цитата: andron81_81 от 23 ноя 2017, 09:31
круто. спасибо. попробую
Только учитывайте, что реквизиты и стандартные реквизиты -- это разные вещи. Здесь не будет выводиться наименование и код элемента справочника.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

alex0402

Спасибо за Сказать спасибо

ilyay

некоторые реквизиты могут существовать только у группы

andron81_81

Цитата: Golickoff от 23 ноя 2017, 09:22
Реквизиты = Метеданные.Справочники.НекийСправочник.Реквизиты;
Для Каждого Реквизит Из Реквизиты Цикл
    Сообщить(Реквизит.Синоним + "    " + НекийСправочникСсылка[Реквизит.Имя]);
КонецЦикла;


всё вышло. спасибо

Теги: справочник 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск