Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 04:57

Видимость показателей в отчете по ролям

Автор kiksi, 22 ноя 2017, 14:29

0 Пользователей и 1 гость просматривают эту тему.

kiksi

Как ограничить видимость показателей в настроке внешнего отчета по ролям 1с упп

kiksi

Цитата: kiksi от 22 ноя 2017, 14:29
Как ограничить видимость показателей в настроке внешнего отчета по ролям 1с упп

Имею в виду код как должен выглядеть?

oleg-x

Смотря какой отчет и как устроен.
Если не скд, то найти где прописаны показатели и выводить в зависимости от роли.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

kiksi

Цитата: oleg-x от 22 ноя 2017, 22:59
Смотря какой отчет и как устроен.
Если не скд, то найти где прописаны показатели и выводить в зависимости от роли.

я в этом деле новичок, помогите, пожалуйста. Пробую пока на группах пользователей. Выведен показатель "Цена", вот надо, чтобы, например, с группой пользователей "ОтделСбыта" этот показатель в настройках отчета был скрыт из видимости, как это сделать? И что меня не так в коде?

УниверсальныйОтчет.ДобавитьПоказатель("Цена", "Цена", истина, "ЧЦ=15; ЧДЦ=2",, "Цена");

   
   СписокГрупп = УправлениеПользователями.ПолучитьСписокГруппПользователя(глЗначениеПеременной("глТекущийПользователь"));
   
   Если СписокГрупп.НайтиПоЗначению(Справочники.ГруппыПользователей.НайтиПоКоду("000000019")) = Неопределено Тогда  //Отдел сбыта
       УниверсальныйОтчет.ДобавитьПоказатель("Цена", "Цена", истина, "ЧЦ=15; ЧДЦ=2",, "Цена");

    Иначе
      УниверсальныйОтчет.ДобавитьПоказатель("Цена", "Цена", ложь, "ЧЦ=15; ЧДЦ=2",, "Цена");

   КонецЕсли;

Добавлено: 23 ноя 2017, 10:59


Цитата: oleg-x от 22 ноя 2017, 22:59
Смотря какой отчет и как устроен.
Если не скд, то найти где прописаны показатели и выводить в зависимости от роли.

Вроде получилось по группам, но теперь по Ролям не получается :xfbnsdfb:
Добавлено: 23 ноя 2017, 11:23


Цитата: oleg-x от 22 ноя 2017, 22:59
Смотря какой отчет и как устроен.
Если не скд, то найти где прописаны показатели и выводить в зависимости от роли.

По ролям тоже получилось, но корректно ли так?:

      
Если РольДоступна("МенеджерСбыта_ПроведениеЗаказа") ИЛИ РольДоступна("МенеджерСбыта2_ПроведениеЗаказа") Тогда
   
   
   УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Цена");
   Иначе
       
   УниверсальныйОтчет.ДобавитьПоказатель("Цена", "Цена", истина, "ЧЦ=15; ЧДЦ=2",, "Цена");
  КонецЕсли;

oleg-x

Если РольДоступна("МенеджерСбыта_ПроведениеЗаказа") ИЛИ РольДоступна("МенеджерСбыта2_ПроведениеЗаказа") Тогда   
   УниверсальныйОтчет.мСтруктураПредставлениеПолей.Вставить("Цена");
Иначе       
   УниверсальныйОтчет.ДобавитьПоказатель("Цена", "Цена", истина, "ЧЦ=15; ЧДЦ=2",, "Цена"); //Зачем добавлять показатель, если пользователю он не нужен согласно роли, я бы просто не выводил его

КонецЕсли;


На роль я также проверяю.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

kiksi

На роль я также проверяю.
[/quote]

Спасибо!:)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск