Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 20:05

автозаполнение элемента формы документа при заполнении другого элемента формы документа

Автор nc1318, 22 ноя 2017, 14:15

0 Пользователей и 1 гость просматривают эту тему.

nc1318

Здравствуйте. 1С 8.3. Справочник "Курсы" с полям "Стоимость" и "Наименование(стандартный реквизит)". Документ "ВнесениеОплат" в табличной части "ПереченьОплат" поля "Учайщийся" (тип СправочникСсылка.Клиенты), "Курс" (СправочникСсылка.Курсы) и Сумма (Число). Как сделать так, чтобы после заполнения поля Курс в документе, автоматически заполнялось поле "Сумма" в документе.  Например, в справочнике есть курс "базы данных", стоимость 5000р. Так вот в документе Курс выбирается из списка справочника, а поле "Сумма" документа должно получить значение "5000р".
Пробывал вот так:


&НаКлиенте
Процедура ПереченьОплатКурсПриИзменении(Элемент)
   Стр = Элементы.ПереченьОплат.ТекущиеДанные;
   Стр.Сумма = ФормированиеДокумента(Стр.Курс);   
КонецПроцедуры

&НаСервереБезКонтекста
Функция ФормированиеДокумента(Наименование)
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |   Курсы.Наименование,
        |   Курсы.Стоимость
        |ИЗ
        |   Справочник.Курсы КАК Курсы
        |ГДЕ
        |   Курсы.Наименование = &Наименование";
   Запрос.УстановитьПараметр("Наименование", Наименование);
    Выборка = Запрос.Выполнить().Выбрать();
   Пока Выборка.Следующий() Цикл
      
   Если Строка(Выборка.Наименование)= Наименование Тогда
      
      Возврат Выборка.Стоимость;      
   КонецЕсли;

   КонецЦикла;
КонецФункции

alex0402

Примерно так:

    Запрос = Новый Запрос("ВЫБРАТЬ
        |   Курсы.Стоимость
        |ИЗ
        |   Справочник.Курсы КАК Курсы
        |ГДЕ
        |   Курсы.Ссылка = &Курс");
    Запрос.УстановитьПараметр("Курс",Курс);
    Выборка = Запрос.Выполнить().Выбрать();
    Выборка.Следующий();
    Сообщить(Выборка.Стоимость);

хотя стоимость лучше хранить где-то в регистре сведений.
Спасибо за Сказать спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск