Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 09:42

Клиент-Серверное взаимоотношение в 1с

Автор NewProgrammist, 13 ноя 2017, 16:07

0 Пользователей и 1 гость просматривают эту тему.

NewProgrammist

Помогите плиз!!! 4 часа не могу с сервера передать на клиент таблицу значения:(:(. На форме имеется ТЗ без колонок. В процессе выполнения кода не возникает никаких ошибок. Однако ТЗ все равно остается ПУСТОЙ.


&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ПриОткрытииНаСервере();
   Элементы.ТЗ.Обновить();
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииНаСервере()
   Таблица = РеквизитФормыВЗначение("Объект.ТЗ");
   Запрос = новый Запрос("ВЫБРАТЬ
                         |   ПродажиОстатки.Организация,
                         |   ПродажиОстатки.Подразделение,
                         |   ПродажиОстатки.Сотрудник,
                         |   ПродажиОстатки.СуммаОстаток
                         |ИЗ
                         |   РегистрНакопления.Продажи.Остатки КАК ПродажиОстатки");
   
   Таблица = Запрос.Выполнить().Выгрузить();
   ЗначениеВРеквизитФормы(Таблица,"Объект.ТЗ");
КонецПроцедуры

oleg-x

Цитата: NewProgrammist от 13 ноя 2017, 16:07
Помогите плиз!!! 4 часа не могу с сервера передать на клиент таблицу значения:(:(. На форме имеется ТЗ без колонок. В процессе выполнения кода не возникает никаких ошибок. Однако ТЗ все равно остается ПУСТОЙ.


&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ПриОткрытииНаСервере();
   Элементы.ТЗ.Обновить();
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииНаСервере()
   Таблица = РеквизитФормыВЗначение("Объект.ТЗ");
   Запрос = новый Запрос("ВЫБРАТЬ
                         |   ПродажиОстатки.Организация,
                         |   ПродажиОстатки.Подразделение,
                         |   ПродажиОстатки.Сотрудник,
                         |   ПродажиОстатки.СуммаОстаток
                         |ИЗ
                         |   РегистрНакопления.Продажи.Остатки КАК ПродажиОстатки");
   
   Таблица = Запрос.Выполнить().Выгрузить();
   ЗначениеВРеквизитФормы(Таблица,"Объект.ТЗ");
КонецПроцедуры
Пройдись отладчиком и посмотри что происходит на каждом этапе
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Теги:
Рейтинг@Mail.ru Rambler's Top100

Поиск