Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 12:22

Настройки запроса для корректного отображения информации в документе

Автор Деметрониус, 10 ноя 2017, 22:46

0 Пользователей и 1 гость просматривают эту тему.

Деметрониус

Здравствуйте, подскажите ученику или направьте на правильный путь.

Есть документ "СдельныйНаряд" в его табличную часть запросом при выборе объекта формы "спецификация номенклатуры" добавляются табличные части состоящие из двух колонок: Технологическая операция и количество.

Так же есть Справочник Спецификации Номенклатуры из которого этим же запросом я беру колонку количество, а затем рассчитываю сумму в четвертой колонке Сумма (регл).

Проблема заключается в том, что я пытаюсь сделать настройки запроса, но всё тщетно. Пробовал делать соединения, но ни одно не подходит и строки запроса дублируются по 4  раза каждая. Перебрал уже все настройки и пришёл сюда за помощью.

Текст процедуры:

&НаСервере
Процедура СпецификацияПродукцииПриИзмененииНаСервере()
   
                     
Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ТехнологическиеОперации.Ссылка,
      |   ТехнологическиеОперации.Расценка,
      |   СпецификацииНоменклатуры.Ссылка КАК Ссылка1,
      |   СпецификацииНоменклатуры.Количество
      |ИЗ
      |   Справочник.СпецификацииНоменклатуры КАК СпецификацииНоменклатуры,
      |   Справочник.ТехнологическиеОперации КАК ТехнологическиеОперации";
   
   //Запрос.УстановитьПараметр("Ссылка", Объект.Спецификация);
   
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
   
   //добавить процедуру очистки заполнения

   Объект.Выработка.Очистить();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Строка = Объект.Выработка.Добавить();
       Строка.ТехнологическаяОперация = ВыборкаДетальныеЗаписи.Ссылка;
       Строка.Расценка = ВыборкаДетальныеЗаписи.Расценка;
       Строка.Количество = ВыборкаДетальныеЗаписи.Количество;
   
       Строка.СуммаРегл = Строка.Количество * Строка.Расценка;
      КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура СпецификацияПродукцииПриИзменении(Элемент)
   СпецификацияПродукцииПриИзмененииНаСервере();
КонецПроцедуры

Zverff

Как понял этот наряд на работу? Запросом здесь не заполнишь ТЧ (В дальнейшем если будут добавляться технологические операция, то будет выгружать весь список). Лучше создать новый документ и регистр для комплекта технологический операция.
Пример: Создаешь новый документ "Комплект". Добавляешь объект спецификации: "Сибирские". Добавляешь "ТЧ" и в ней заполняете технологические операция (Чистка лука, разделка мясо, изготовление фарша) и записываете в регистр, после того как все сделаете то можете брать данные из регистра по срез по последнему.

пс: Извините что написал не внятно, но я торопился))

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск