Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 19:09

не обновляется уже открытая форма после изменений

Автор khenata, 08 ноя 2017, 11:19

0 Пользователей и 1 гость просматривают эту тему.

khenata

Создана внешняя обработка. Добавляется кнопкой в документ в 1С ЗУП 3.1 в документ ДанныеДляРасчетаЗапрлаты. В открытой форме нажатие на кнопку вызывает обработку, делает изменения, но форма не обновляется. Ф-ция Сообщить выдает правильные результаты изменений.Что не так в коде, может был такой же вопрос? Если такой код запускаю в документе РазовоеНачисление - все работает.
&НаКлиенте
Процедура ВыполнитьКоманду(ИдентификаторКоманды,ОбъектыНазначенияМассив) Экспорт
   ВладелецФормы.Модифицированность = Истина;
   ОснРеквизит1 = ВладелецФормы.Объект;      
   ЗаполнитьОбъект(ОснРеквизит1);
   КопироватьДанныеФормы(ОснРеквизит1,ВладелецФормы.Объект);
КонецПроцедуры
&НаСервере
Функция ЗаполнитьОбъект(ОснРеквизит1)
   ТЧ =ОснРеквизит1.ЗначенияПоказателей;
   Для Каждого Строка ИЗ ТЧ Цикл
      Если СтрСравнить(Строка.Показатель, "СдельноНорма") = 0 Тогда
         Строка.Значение = Строка.Значение -15;
                        Сообщить(Строка.Показатель);
                  Сообщить(Строка.Значение);
           КонецЕсли;
        КонецЦикла;
КонецФункции



Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск