Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
10 авг 2022, 23:46

Список выбора

Автор Dmitry Qwe, 06 ноя 2017, 12:09

0 Пользователей и 1 гость просматривают эту тему.

Dmitry Qwe

Есть вот такая форма обработки

Хочу чтобы, если у меня в колонке ПВХ например, находится элемент "Элемент1" то в колонке характеристика у меня был бы список выбора из 2х строк, "Да", "Нет". Но в конфигураторе почему-то недоступно создание списка выбора

Dmitry Qwe


Перезалил фото, в первом посте плохо видно

alex0402

Характеристика должен иметь тип Характеристика.Имя и где-то там в свойствах прописать связ с ПВХ и оно все должно отрабатывать автоматом.
Спасибо за Сказать спасибо

Dmitry Qwe

Цитата: alex0402 от 06 ноя 2017, 13:15
Характеристика должен иметь тип Характеристика.Имя и где-то там в свойствах прописать связ с ПВХ и оно все должно отрабатывать автоматом.
В свойствах этих полей на форме искать или в свойствах самого ПВХ?

alex0402

В свойствах реквизитов ТЧ обработки.
Спасибо за Сказать спасибо

Dmitry Qwe

alex0402, Если честно ничего такого так и не нашел, можете указать конкретнее что искать или хотябы где про это можно почитать.
P.S. И можно ли сделать с помощью этого то что я в первом посту описывал? Т.е есть предопределенный элемент в ПВХ с типом строка и для этого элемента нужно сделать список выбора

oleg-x

Цитата: alex0402 от 06 ноя 2017, 13:15
Характеристика должен иметь тип Характеристика.Имя и где-то там в свойствах прописать связ с ПВХ и оно все должно отрабатывать автоматом.
Я так понимаю имеется виду в свойствах реквизита характеристики, есть связь параметров выбора, там выбрать Строка.ПВХ и на уровне платформы будет отбор.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Dmitry Qwe

oleg-x, Вот так?

Всеравно нет возможности добавить список выбора

oleg-x

Список выбора там не добавишь, но будут отображены только те элементы, которые возможно выбрать для данной ПВХ.
Если хочешь сделать свой особый список, тогда так:
1) Включи список для характеристик.
2) Сделай заполнение списка при изменение или подборе ПВХ.
Как то так, в синтаксисе могу немного ошибаться, написал на память.
Процедура ПриИзмененииПВХ()
    ЗаполнитьСписокХарактеристики(Строка.ПВХ);
КонецПроцедуры

Процедура ЗаполнитьСписокХарактеристики(ПВХ)
    Элементы.Характеристики.СписокВыбора.Очистить();
    //Формируем список значений и добавляем в поле.
    Для каждого стр из списка Цикл
        Элементы.Реквизит.СписокВыбора.Вставить(0,Стр.Значение);
    КонецЦикла;
КонецПроцедуры
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Dmitry Qwe

Цитата: oleg-x от 07 ноя 2017, 23:29
Список выбора там не добавишь, но будут отображены только те элементы, которые возможно выбрать для данной ПВХ.
Если хочешь сделать свой особый список, тогда так:
1) Включи список для характеристик.
2) Сделай заполнение списка при изменение или подборе ПВХ.
Как то так, в синтаксисе могу немного ошибаться, написал на память.
Процедура ПриИзмененииПВХ()
    ЗаполнитьСписокХарактеристики(Строка.ПВХ);
КонецПроцедуры

Процедура ЗаполнитьСписокХарактеристики(ПВХ)
    Элементы.Характеристики.СписокВыбора.Очистить();
    //Формируем список значений и добавляем в поле.
    Для каждого стр из списка Цикл
        Элементы.Реквизит.СписокВыбора.Вставить(0,Стр.Значение);
    КонецЦикла;
КонецПроцедуры


С помощью данного кода один и тот же список выбора применится ко всем элементам колонки ПВХ, мне нужно что бы если в колонке пвх допустим есть предопределенный реквизит, например "Элемент1" то именно для него заполняется этот список выбора

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск