Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 09:51

Выбор периода [ДиалогРедактированияСтандартногоПериода]

Автор MuI_I_Ika, 02 ноя 2017, 11:12

0 Пользователей и 1 гость просматривают эту тему.

MuI_I_Ika



Приведенный ниже код служит примером для работы с диалогом выбора периода. Вы создаете на форме кнопку выбора периода, которая позволяет заполнить дату начала и дату окончания.

&НаКлиенте
Процедура ВыборПериода(Команда)
Диалог = Новый ДиалогРедактированияСтандартногоПериода();
Период = Новый СтандартныйПериод();
Период.ДатаНачала = Объект.НачалоПериода;
Период.ДатаОкончания = Объект.КонецПериода;
Диалог.Период = Период;

Диалог.Показать(Новый ОписаниеОповещения("УстановитьПериод",ЭтаФорма));
КонецПроцедуры

&НаКлиенте
Процедура УстановитьПериод(ЗначениеПериода,ДополнительныеПереметры = неопределено) Экспорт

Если ЗначениеПериода <> Неопределено Тогда
Объект.НачалоПериода = ЗначениеПериода.ДатаНачала;
Объект.КонецПериода = ЗначениеПериода.ДатаОкончания;
КонецЕсли;

КонецПроцедуры

Теги:

Похожие темы (3)

Рейтинг@Mail.ru Rambler's Top100

Поиск