Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 09:39

Поле объекта не обнаружено (СтавкаНДС) помогите решить проблему

Автор Ruseq Key, 24 окт 2017, 17:38

0 Пользователей и 1 гость просматривают эту тему.

Ruseq Key

Помогите, пожалуйста, решить проблему
сравнивал модули конфигураторов, кеш чистил, обновлял - не помогает
(1С8.3БП проф)
При вызове на печать упд (Продажи-реализация) ошибка Поле объекта не обнаружено (СтавкаНДС)

{ОбщийМодуль.УчетНДС.Модуль(11697)}: Поле объекта не обнаружено (СтавкаНДС)
         ОбластьМакета.Параметры.СтавкаНДС = "--";

{ОбщийМодуль.УчетНДС.Модуль(11769)}: Поле объекта не обнаружено (СтавкаНДС)
   Если ОбластьМакета.Параметры.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС Тогда

Если ОбластьМакета.Параметры.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС Тогда
ОбластьМакета.Параметры.СтавкаНДС = "без НДС";
ОбластьМакета.Параметры.СуммаНДС  = "без НДС";
КонецЕсли;
Если НЕ ЗначениеЗаполнено(СтрокаДокумента.СтавкаНДС) Тогда
ОбластьМакета.Параметры.СтавкаНДС = "--";
Если СтрокаДокумента.СуммаНДС = 0 Тогда
ОбластьМакета.Параметры.СуммаНДС = "--";
КонецЕсли;
КонецЕсли;



MuI_I_Ika

Что-то у вас с макетом не то. Возможно печатная форма внешняя и после обновления конфигурации она перестала работать.

Ruseq Key

В конфигураторах разных баз макеты сравнивал - одинаковые, а в самой 1с в "сломанной" макет не знаю как иначе открыть, кроме как через форму печати

MuI_I_Ika

Администрирование/Печатные формы отчеты и обработки/Дополнительные отчеты и обработки

И там ищите печатную форму УПД

Ruseq Key

Цитата: MuI_I_Ika от 24 окт 2017, 17:54
Администрирование/Печатные формы отчеты и обработки/Дополнительные отчеты и обработки

И там ищите печатную форму УПД
Спасибо большое! Там и была проблема. отличался параметр от макета в конфигураторе

Геннадий на Оби

Цитата: Ruseq Key от 24 окт 2017, 17:38
Помогите, пожалуйста, решить проблему
сравнивал модули конфигураторов, кеш чистил, обновлял - не помогает
(1С8.3БП проф)
При вызове на печать упд (Продажи-реализация) ошибка Поле объекта не обнаружено (СтавкаНДС)
Версия - 4 числа - какая?
Что с чем сравнивали?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск