Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 18:36

Проблема с установкой флажков

Автор Эндрю Малышев, 19 окт 2017, 10:06

0 Пользователей и 1 гость просматривают эту тему.

Эндрю Малышев

Всем добрый день, в конфигураторе, необходим вывод выбранных параметров с помощью установки флажков, база 1С:ERP, но постоянно оишбки разные
{Документ.СБ_РезультатыПланированияПроизводства.Форма.ФормаЭлемента.Форма(175,35)}: Тип не определен (СоответствиеФлажка)
Объект.Продукция.Выборка = Новый <<?>>СоответствиеФлажка(Истина); (Проверка: Тонкий клиент)

Эндрю Малышев

убрал запись "Новый", все равно не помогло
Добавлено: 19 окт 2017, 10:38



Добавлено: 19 окт 2017, 11:28


не много разобрался, что соответствиефлажков, компилятор не понимает что это

Kironten

Цитата: Эндрю Малышев от 19 окт 2017, 10:37
не много разобрался, что соответствиефлажков, компилятор не понимает что это
Я вам больше скажу, не только компилятор не понимает, что это.
Что это за предопределенная сущность такая, соответствиефлажков?

Эндрю Малышев

Цитата: Kironten от 19 окт 2017, 13:47
Цитата: Эндрю Малышев от 19 окт 2017, 10:37
не много разобрался, что соответствиефлажков, компилятор не понимает что это
Я вам больше скажу, не только компилятор не понимает, что это.
Что это за предопределенная сущность такая, соответствиефлажков?
Это все я исправил. Мне получается нужно сделать чтобы количество отмеченных флажков, записывалось в массив, далее из этого массива брал ось количество выбранных строк и создавались документы по выбранным срокам, а если ничего не выбрано то выводился документ со всех строк

Kironten

Цитата: Эндрю Малышев от 19 окт 2017, 13:53
... а если ничего не выбрано то выводился документ со всех строк
Что сие значит?

Эндрю Малышев

Цитата: Kironten от 19 окт 2017, 14:27
Цитата: Эндрю Малышев от 19 окт 2017, 13:53
... а если ничего не выбрано то выводился документ со всех строк
Что сие значит?
Это значит что в табличной части документа у меня есть данные, я добавляю туда столбец с флажками, если я выбираю какие либо строки и ставлю флажок, то при нажатии кнопку создать заказ у меня выводится заказ по выбранным строками, а если ничего не выбрал то выводится заказ по всем строкам

Kironten

Цитата: Эндрю Малышев от 19 окт 2017, 14:32
Это значит что в табличной части документа у меня есть данные, я добавляю туда столбец с флажками, если я выбираю какие либо строки и ставлю флажок, то при нажатии кнопку создать заказ у меня выводится заказ по выбранным строками, а если ничего не выбрал то выводится заказ по всем строкам
Я так полагаю флажок - это реквизит тч под названием выборка?
Тогда я бы делал так:
...
МассивСтрок = Новый Массив;
СчетчикФлагов = 0;
Для Каждого Стр Из Товары Цикл
    МассивСтрок.Добавить(Стр);
    Если Стр.Выборка Тогда
        СчетчикФлагов = СчетчикФлагов + 1;
    КонецЕсли;
КонецЦикла;

СоздатьДокументы(МассивСтрок, СчетчикФлагов);
...

Процедура СоздатьДокументы(МассивСтрок, СчетчикФлагов)
//создаем документ
...
//Заполняем табличчную часть
Для Каждого Стр Из МассивСтрок Цикл
    Если СчетчикФлагов <> 0 Тогда
        Если Не Стр.Выборка Тогда
            Продолжить;
        КонецЕсли;
    КонецЕсли;
    ...
КонецЦикла;
...
КонецПроцедуры

Эндрю Малышев

Цитата: Kironten от 19 окт 2017, 14:45
Цитата: Эндрю Малышев от 19 окт 2017, 14:32
Это значит что в табличной части документа у меня есть данные, я добавляю туда столбец с флажками, если я выбираю какие либо строки и ставлю флажок, то при нажатии кнопку создать заказ у меня выводится заказ по выбранным строками, а если ничего не выбрал то выводится заказ по всем строкам
Я так полагаю флажок - это реквизит тч под названием выборка?
Тогда я бы делал так:
...
МассивСтрок = Новый Массив;
СчетчикФлагов = 0;
Для Каждого Стр Из Товары Цикл
    МассивСтрок.Добавить(Стр);
    Если Стр.Выборка Тогда
        СчетчикФлагов = СчетчикФлагов + 1;
    КонецЕсли;
КонецЦикла;

СоздатьДокументы(МассивСтрок, СчетчикФлагов);
...

Процедура СоздатьДокументы(МассивСтрок, СчетчикФлагов)
//создаем документ
...
//Заполняем табличчную часть
Для Каждого Стр Из МассивСтрок Цикл
    Если СчетчикФлагов <> 0 Тогда
        Если Не Стр.Выборка Тогда
            Продолжить;
        КонецЕсли;
    КонецЕсли;
    ...
КонецЦикла;
...
КонецПроцедуры

Да это выборка. Я её добавил. Но вот я получается делаю флажок и документ не создавался, а если не делал то выводились все строки

Kironten

Лады. Показывайте конечный код, будем разбираться.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск