Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 12:30

Ошибка в программировании на 1С 8.3

Автор Souris Cates, 15 окт 2017, 21:16

0 Пользователей и 1 гость просматривают эту тему.

Souris Cates

Мой код:

https://pastebin.com/AnGr9Gkp

Моя ошибка:

{Документ. ОказаниеУслуги. Форма. ФормаДокумента. Форма (55,1)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
<<?>>КонецЦикла; (Проверка: Сервер)
{Документ. ОказаниеУслуги. Форма. ФормаДокумента. Форма (55,1)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
<<?>>КонецЦикла; (Проверка: Тонкий клиент)

Если что, у меня 1С 8.3 учебная версия

oleg-x

Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Souris Cates

Когда я так сделал, система выдала следующие ошибки:

{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(15,2)}: Переменная не определена (Документы)
   <<?>>Документы.ОказаниеУслуги.Печать(ТабДок, ПараметрКоманды); (Проверка: Тонкий клиент)
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(16,2)}: Переменная не определена (Запрос)
   <<?>>Запрос.Параметры.Вставить("Ссылка", Ссылка); (Проверка: Тонкий клиент)
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(17,12)}: Переменная не определена (Запрос)
   Выборка = <<?>>Запрос.Выполнить().Выбрать(); (Проверка: Тонкий клиент)
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(16,38)}: Переменная не определена (Ссылка)
   Запрос.Параметры.Вставить("Ссылка", <<?>>Ссылка); (Проверка: Тонкий клиент)
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(18,21)}: Переменная не определена (Макет)
   ОбластьЗаголовок = <<?>>Макет.ПолучитьОбласть("Заголовок"); (Проверка: Тонкий клиент)
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(19,10)}: Переменная не определена (Макет)
   Шапка = <<?>>Макет.ПолучитьОбласть("Шапка"); (Проверка: Тонкий клиент)
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(20,37)}: Переменная не определена (Макет)
   ОбластьПереченьНоменклатурыШапка = <<?>>Макет.ПолучитьОбласть("ПереченьНоменклатурыШапка"); (Проверка: Тонкий клиент)
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(21,32)}: Переменная не определена (Макет)
   ОбластьПереченьНоменклатуры = <<?>>Макет.ПолучитьОбласть("ПереченьНоменклатуры"); (Проверка: Тонкий клиент)
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(22,16)}: Переменная не определена (Макет)
   ОбластьИтог = <<?>>Макет.ПолучитьОбласть("Всего"); (Проверка: Тонкий клиент)

oleg-x

Потому что они не определены, где у вас описание данных переменных?
Что такое документы?
Что такое запрос? по идее должно быть такое

Запрос = Новый Запрос;
Запрос.Текст = "Текст запроса";


Или в параметрах процедуры должны быть эти переменные.
Такое ощущение что вы откуда то просто скопировали текст.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

vitasw

+ почитайте про контексты исполнения кода &НаКлиенте &НаСервере.

Souris Cates

Прочитал. Ввёл контекст &НаКлиентеНаСервере с тем же кодом. Синтаксических ошибок не обнаружило. Но при запуске документа "ОказаниеУслуги" выдаёт следующие ошибки:
Ошибка инициализации модуля: Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма
по причине:
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(16,2)}: Переменная не определена (Документ)
   <<?>>Документ.ОказаниеУслуги.Печать(ТабДок, ПараметрКоманды);
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(17,2)}: Переменная не определена (Запрос)
   <<?>>Запрос.Параметры.Вставить("Ссылка", Ссылка);
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(18,12)}: Переменная не определена (Запрос)
   Выборка = <<?>>Запрос.Выполнить().Выбрать();
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(17,38)}: Переменная не определена (Ссылка)
   Запрос.Параметры.Вставить("Ссылка", <<?>>Ссылка);
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(19,21)}: Переменная не определена (Макет)
   ОбластьЗаголовок = <<?>>Макет.ПолучитьОбласть("Заголовок");
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(20,10)}: Переменная не определена (Макет)
   Шапка = <<?>>Макет.ПолучитьОбласть("Шапка");
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(21,37)}: Переменная не определена (Макет)
   ОбластьПереченьНоменклатурыШапка = <<?>>Макет.ПолучитьОбласть("ПереченьНоменклатурыШапка");
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(22,32)}: Переменная не определена (Макет)
   ОбластьПереченьНоменклатуры = <<?>>Макет.ПолучитьОбласть("ПереченьНоменклатуры");
{Документ.ОказаниеУслуги.Форма.ФормаДокумента.Форма(23,16)}: Переменная не определена (Макет)
   ОбластьИтог = <<?>>Макет.ПолучитьОбласть("Всего");

alex0402

Цитата: Souris Cates от 18 окт 2017, 23:39Прочитал

Администрирование - Параметры - Модули - Проверка - какие галочки стоят?
Спасибо за Сказать спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск