Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 12:35

Замена пробелов в строке

Автор Dmitry Qwe, 15 окт 2017, 14:59

0 Пользователей и 1 гость просматривают эту тему.

Dmitry Qwe

Хочу в строке все большие пробелы заменить на одинарные, но почему то цикл у меня выходит бесконечный

ИсхСтрока1 = "Привет                Да    Нет";
    Пока СтрНайти(ИсхСтрока1, "  ") Цикл
         Строка = СтрЗаменить (ИсхСтрока1, "  "," ");
  КонецЦикла;


alex0402

Цитата: Dmitry Qwe от 15 окт 2017, 14:59ИсхСтрока1 = "Привет                Да    Нет";     Пока СтрНайти(ИсхСтрока1, "  ") Цикл          Строка = СтрЗаменить (ИсхСтрока1, "  "," ");   КонецЦикла;



ИсхСтрока1 = "Привет                Да    Нет";   
Пока СтрНайти(ИсхСтрока1, "  ") Цикл       
   ИсхСтрока1 = СтрЗаменить (ИсхСтрока1, "  "," "); 
КонецЦикла;
Спасибо за Сказать спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск