Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 13:18

Программное изменение фона кнопок

Автор nmtn, 13 окт 2017, 11:52

0 Пользователей и 1 гость просматривают эту тему.

nmtn

Доброго времени суток.
Есть группа с кнопками на форме внешней обработки. Можно ли сделать так, что бы кнопки меняли цвет при нажатии на них?

oleg-x

Цитата: nmtn от 13 окт 2017, 11:52
Доброго времени суток.
Есть группа с кнопками на форме внешней обработки. Можно ли сделать так, что бы кнопки меняли цвет при нажатии на них?
Можно
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

nmtn

Цитата: oleg-x от 13 окт 2017, 12:01
Цитата: nmtn от 13 окт 2017, 11:52
Доброго времени суток.
Есть группа с кнопками на форме внешней обработки. Можно ли сделать так, что бы кнопки меняли цвет при нажатии на них?
Можно
Не подскажите как лучше сделать: через цикл или условием?

oleg-x

Через событие при нажатие на кнопку.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Golickoff

Когда-то меня тоже заинтересовал подобный вопрос...
Для А = 0 По 255 Цикл //Красный -> Жёлтый
ЭтаФорма.Элементы.Чпоньк.ЦветФона = Новый Цвет(255,А,0);
ОбновитьОтображениеДанных();
В = ТекущаяУниверсальнаяДатаВМиллисекундах();
Пока (ТекущаяУниверсальнаяДатаВМиллисекундах() - В) < 35 Цикл
КонецЦикла;
КонецЦикла;
Для А = 0 По 255 Цикл //Жёлтый -> Зелёный
ЭтаФорма.Элементы.Чпоньк.ЦветФона = Новый Цвет(255-А,255,0);
ОбновитьОтображениеДанных();
В = ТекущаяУниверсальнаяДатаВМиллисекундах();
Пока (ТекущаяУниверсальнаяДатаВМиллисекундах() - В) < 35 Цикл
КонецЦикла;
КонецЦикла;
Для А = 0 По 255 Цикл //Зелёный -> Голубой
ЭтаФорма.Элементы.Чпоньк.ЦветФона = Новый Цвет(0,255,А);
ОбновитьОтображениеДанных();
В = ТекущаяУниверсальнаяДатаВМиллисекундах();
Пока (ТекущаяУниверсальнаяДатаВМиллисекундах() - В) < 35 Цикл
КонецЦикла;
КонецЦикла;
Для А = 0 По 255 Цикл //Голубой -> Синий
ЭтаФорма.Элементы.Чпоньк.ЦветФона = Новый Цвет(0,255-А,255);
ОбновитьОтображениеДанных();
В = ТекущаяУниверсальнаяДатаВМиллисекундах();
Пока (ТекущаяУниверсальнаяДатаВМиллисекундах() - В) < 35 Цикл
КонецЦикла;
КонецЦикла;
Для А = 0 По 255 Цикл //Синий -> Фиолетовый
ЭтаФорма.Элементы.Чпоньк.ЦветФона = Новый Цвет(А,0,255);
ОбновитьОтображениеДанных();
В = ТекущаяУниверсальнаяДатаВМиллисекундах();
Пока (ТекущаяУниверсальнаяДатаВМиллисекундах() - В) < 35 Цикл
КонецЦикла;
КонецЦикла;
Для А = 0 По 255 Цикл //Фиолетовый -> Красный
ЭтаФорма.Элементы.Чпоньк.ЦветФона = Новый Цвет(255,0,255-А);
ОбновитьОтображениеДанных();
В = ТекущаяУниверсальнаяДатаВМиллисекундах();
Пока (ТекущаяУниверсальнаяДатаВМиллисекундах() - В) < 35 Цикл
КонецЦикла;
КонецЦикла;
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск