Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 09:10

1с 8.3 Представление ссылки на справочник

Автор illiona, 09 окт 2017, 07:08

0 Пользователей и 1 гость просматривают эту тему.

illiona

Добрый день. Не могу разобраться с представление ссылки на справочник.
Есть справочник "Транспортное Средство" с реквизитами Наименование, Гос номер, Вес.
В документе поступление есть поле на форме - Транспорт - это ссылка на справочник "Транспортное Средство"
Как при выборе в документе из поля Транспорт, чтоб отображалось Наименование + Гос.номер?, отображается при выборе только наименование
Заранее всем спасибо)

Golickoff

В модуль менеджера справочника добавьте следующие процедуры
Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Представление = Данные.Наименование + ", " + Данные.РеквизитВКоторомХранитсяГосНомер;
КонецПроцедуры

Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Поля.Добавить("Наименование");
КонецПроцедуры
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

illiona

Цитата: Golickoff от 09 окт 2017, 07:48
В модуль менеджера справочника добавьте следующие процедуры
Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Представление = Данные.Наименование + ", " + Данные.РеквизитВКоторомХранитсяГосНомер;
КонецПроцедуры

Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Поля.Добавить("Наименование");
КонецПроцедуры


Спасибо большое!
Такой код получился
Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
      Представление = Данные.Наименование + ", " + Данные.ГосНомер;
КонецПроцедуры

Процедура ОбработкаПолученияПолейПредставления(Поля, СтандартнаяОбработка)
    СтандартнаяОбработка = Ложь;
    Поля.Добавить("Наименование");
   Поля.Добавить("ГосНомер");
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск