Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 10:53

Напоминание о днях рождения

Автор Prilforreal, 05 окт 2017, 17:04

0 Пользователей и 1 гость просматривают эту тему.

Prilforreal

Добрый день, делаю напоминание о днях рождения при начале работы системы:

Процедура ПриОткрытии()
      Выборка = Справочники.Контрагент.Выбрать();
   Пока Выборка.Следующий() Цикл
      Если Выборка.ЭтоГруппа Тогда Продолжить;
      КонецЕсли;
      Если Месяц(ТекущаяДата()) = Месяц(Выборка.ДР) И
         //Г = Год(ТекущаяДата()) - Год(Выборка.ДатаРождения) И
          День(ТекущаяДата()) = День(Выборка.ДР) Тогда
          Сообщить("Сегодня  исполнилось " + ( Год(ТекущаяДата()) - Год(Выборка.ДР)) + "  лет  " +  Выборка.Наименование);
        ИначеЕсли Месяц(ТекущаяДата()) = Месяц(Выборка.ДР) И
          День(ТекущаяДата()) + 1 = День(Выборка.ДР) Тогда
          Сообщить("Завтра  исполняется  " +( Год(ТекущаяДата()) - Год(Выборка.ДР) + 1) + "  лет  "+  Выборка.Наименование);
       
        КонецЕсли;
  КонецЦикла;

     КонецПроцедуры


Подскажите будьте добры, как мне вместо сообщить, записать результат выборки в переменную и вывести в надписи на форме?


pavl_vs

Цитата: Prilforreal от 05 окт 2017, 17:04
Подскажите будьте добры, как мне вместо сообщить, записать результат выборки в переменную и вывести в надписи на форме?

1. Можно, не создавая какую-то дополнитльную форму, использовать, например, стандартную "Предупреждение", на которой разместите результат запроса в виде форматированного текста.
Свойства формы можно посмотреть в Синтакс-помощнике (Глобальный контекст / Процедуры и функции ...); конкретнее можно было бы посоветовать для конкретной конфигурации, которая не названа.

2. А вот то, что это Предупреждение  должно возникать из процедуры "ПриОткрытии", вызывает сомнение - при открытии чего?

Kironten

Хорошо что первого января никто не работает.
А то массово поздравлять сотрудников с незаполненными датами рождения...

pavl_vs

Kironten, все зависит от того, что там в запросе и в его обработке написать;
кроме того о массовости у ТС ни слова - не стоит домысливать.

Теги: формы 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск