Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 03:54

Сохранение файла в базу

Автор Aleks26, 04 окт 2017, 10:25

0 Пользователей и 1 гость просматривают эту тему.

Aleks26

Подскажите пожалуйста, написал код из учебника по сохранению файла в базу 1с, а он не работает в части этого самого сохранения.
Вот код:
&НаКлиенте
Процедура ЗагрузитьСДиска(Команда)

АдресВХранилище = "";
ВыбранноеИмяФайла = "";

Если ПоместитьФайл(АдресВХранилище, , ВыбранноеИмяФайла, , УникальныйИдентификатор) Тогда
Файл = Новый Файл(ВыбранноеИмяФайла);
ИмяФайла = Файл.Имя;
СсылкаНаФайлВоВременномХранилище = АдресВХранилище;
Модифицированность = Истина;
КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

Если ЭтоАдресВременногоХранилища(СсылкаНаФайлВоВременномХранилище) Тогда
ДвоичныеДанные = ПолучитьИзВременногоХранилища(СсылкаНаФайлВоВременномХранилище);
ТекущийОбъект.ХранилищеФайлов = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных(9));
ТекущийОбъект.ИмяФайла = ИмяФайла;
КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

Если ЭтоАдресВременногоХранилища(СсылкаНаФайлВоВременномХранилище) Тогда
УдалитьИзВременногоХранилища(СсылкаНаФайлВоВременномХранилище);
КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура СохранитьНаДиск(Команда)

Если Объект.ИмяФайла = "" Тогда
Предупреждение("В базе нет сохраненного файла!");
Иначе
СсылкаНаФайлВБазе = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "ХранилищеФайлов");
ПолучитьФайл(СсылкаНаФайлВБазе, Объект.ИмяФайла);
КонецЕсли;

КонецПроцедуры


Посмотрите, может что то неправильно. По сути при нажатии кнопки Записать не выполняется процедура ПередЗаписьюНаСервере. Я не могу понять почему.

vitasw

В параметрах формы процедура прописана?

Aleks26

Цитата: vitasw от 04 окт 2017, 12:18
В параметрах формы процедура прописана?
Да, это процедура из событий формы.
Добавлено: 04 окт 2017, 13:27


Обнаружил сам :). У реквизита формы поставил ограниченную длину и ссылка прост не помещалась вся.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск