Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 18:24

свернуть таблицу значений по строке

Автор Св Ч, 01 окт 2017, 16:59

0 Пользователей и 1 гость просматривают эту тему.

Св Ч

Добрый День!
у таблицы значений есть метод   Итог
ЦитироватьЭтаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Значение.Итог(Колонка.Имя)
- т.е. получаем итог по имени колонки.

кто знает какие есть методы подсчета итога по каждой строке (по колонкам). Т.е.
ТЗ.Итог(номер строки) - чтобы найти все числа по данной строке по указанным колонкам?:dfbsdfbsdf: Заранее спасибо.

oleg-x

Метода нет, напиши свою процедуру.
Обойди каждое значение в строке и если тип значения число прибавляй, если нет, пропускай.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

AIFrame

Просуммировать колонки в строке, с указанием колонок?
МассивКолонок = Новый Массив;
МассивКолонок.Добавить("Колонка1");
МассивКолонок.Добавить("Колонка2");
МассивКолонок.Добавить("Колонка3");
// и т.д.

// Допустим, строку уже получили
// СтрокаТЧ - то, с чем работаем
// Какой-то цикл начался
СуммаСтроки = 0;
Для ИНД = 0 ПО МассивКолонок.Количество() - 1 Цикл
ИмяКолонки = МассивКолонок[ИНД];
СуммаСтроки = СуммаСтроки + СтрокаТЧ[ИмяКолонки];
КонецЦикла;
Сообщить(СуммаСтроки);
// Какой-то цикл кончился

Если все колонки содержат число и нужно тупо проссумировать по всем
СуммаСтроки = 0;
Для Каждого КолонкаТЧ из ТЧ.Колонки Цикл
СуммаСтроки = СуммаСтроки + СтрокаТЧ[КолонкаТЧ.Имя];
КонецЦикла;
Сообщить(СуммаСтроки);

Но это можно и проверить
СуммаСтроки = 0;
Для Каждого КолонкаТЧ из ТЧ.Колонки Цикл
Если ТипЗнч(СтрокаТЧ[КолонкаТЧ.Имя]) = Тип("Число") Тогда
СуммаСтроки = СуммаСтроки + СтрокаТЧ[КолонкаТЧ.Имя];
КонецЕсли;
КонецЦикла;
Сообщить(СуммаСтроки);



Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск