Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 июл 2022, 09:41

Не установлен параметр

Автор bustabar, 19 сен 2017, 15:32

0 Пользователей и 1 гость просматривают эту тему.

bustabar

Запускаю внешнюю обработку, и получаю вот такую ошибку. Вроде же все параметры установлены, либо просто я слепой и тупой.
Ошибка при вызове метода контекста (Выполнить): {(6, 83)}: Не задано значение параметра "Ccылка"
ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления.Ссылка = <<?>>&Ccылка

Код печати:
Функция Печать() Экспорт
ТабДок = новый ТабличныйДокумент;
Макет = ПолучитьМакет("Макет");
ОблШапка = Макет.ПолучитьОбласть("Шапка");
ОблШапка.Параметры.Дата = Формат(СсылкаНаОбъект.Дата,"ДФ=dd.MM.yyyy");
ОблШапка.Параметры.Номер = СсылкаНаОбъект.НомерПеч;
ТабДок.Вывести(ОблШапка);
Запрос = новый запрос("ВЫБРАТЬ
                      | ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления.ВидРасчета КАК ВидРасчета
                      |ИЗ
                      | Документ.ВводСведенийОПлановыхНачисленияхРаботниковОрганизаций.ОсновныеНачисления КАК ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления
                      |ГДЕ
                      | ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления.Ссылка = &Ccылка
                      |
                      |СГРУППИРОВАТЬ ПО
                      | ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления.ВидРасчета");
Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект);
Результат = Запрос.Выполнить().Выбрать();
НомерНач = 1;
Пока Результат.Следующий() Цикл
ОблСтрокаНач = Макет.ПолучитьОбласть("СтрокаНач");
ОблСтрокаНач.Параметры.НомерНачисления = НомерНач;
НомерНач = НомерНач + 1;
    ОблСтрокаНач.Параметры.Начисление = Результат.ВидРасчета;
ТабДок.Вывести(ОблСтрокаНач);
ЗапросПодр = новый запрос("ВЫБРАТЬ
                                   | ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления.Сотрудник,
                                   | ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления.Валюта1,
                                   | ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления.Комментарий,
                                   | РаботникиОрганизацийСрезПоследних.Должность,
                                   | РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации КАК Подразделение,
                                   | ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления.ДатаДействия,
                                   | ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления.ДатаДействияКонец
                                   |ИЗ
                                   | Документ.ВводСведенийОПлановыхНачисленияхРаботниковОрганизаций.ОсновныеНачисления КАК ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления
                                   | ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.РаботникиОрганизаций.СрезПоследних(&Период, ) КАК РаботникиОрганизацийСрезПоследних
                                   | ПО ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления.Сотрудник = РаботникиОрганизацийСрезПоследних.Сотрудник
                                   |ГДЕ
                                   | ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления.ВидРасчета = &ВидРасчета
                                   | И ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления.Ссылка = &Ссылка
                                   |ИТОГИ ПО
                                   | Подразделение");
ЗапросПодр.УстановитьПараметр("Ссылка",СсылкаНаОбъект);
ЗапросПодр.УстановитьПараметр("ВидРасчета",Результат.ВидРасчета);
ЗапросПодр.УстановитьПараметр("Период",СсылкаНаОбъект.Дата);
РезПодразделение = ЗапросПодр.Выполнить().Выбрать();
Итог = Истина;
НомерДетНач = 1;
Пока РезПодразделение.Следующий() Цикл
Если Итог Тогда
ОблСтрокаПодр = Макет.ПолучитьОбласть("СтрокаПодр");
ОблСтрокаПодр.Параметры.НомерДетНач = НомерДетНач;
ОблСтрокаПодр.Параметры.Подразделение = РезПодразделение.Подразделение;
ОблСтрокаПодр.Параметры.ПериодНач = РезПодразделение.ДатаДействия;
ОблСтрокаПодр.Параметры.ПериодКон = РезПодразделение.ДатаДействияКонец;
ТабДок.Вывести(ОблСтрокаПодр);
НомерДетНач = НомерДетНач+0.1;
Итог = Ложь;
Прервать;
КонецЕсли;
ОблСтрокаДет = Макет.ПолучитьОбласть("ОблСтрокаДет");
ОблСтрокаДет.Параметры.Детали = "- "+РезПодразделение.Сотрудник+" - "+РезПодразделение.Должность+"в сумі "+РезПодразделение.Валюта1+" грн.";
ТабДок.Вывести(ОблСтрокаДет);
Если Не РезПодразделение.Следующий() Тогда
ОблОсн = Макет.ПолучитьОбласть("СтрокаОсн");
ОблОсн.Параметры.Основание = РезПодразделение.Комментарий;
ТабДок.Вывести(ОблОсн);
КонецЕсли;
КонецЦикла;
ОблОсн = Макет.ПолучитьОбласть("СтрокаОсн");
Итог = Истина;
НомерДетНач = Цел(НомерДетНач+1);
КонецЦикла;
ОблПодвал = Макет.ПолучитьОбласть("Подвал");
ЗапросПодвал = новый запрос("ВЫБРАТЬ
                            | РаботникиОрганизацийСрезПоследних.Сотрудник
                            |ИЗ
                            | РегистрСведений.РаботникиОрганизаций.СрезПоследних(&Период, ) КАК РаботникиОрганизацийСрезПоследних
                            |ГДЕ
                            | РаботникиОрганизацийСрезПоследних.Должность = &Должность");
ЗапросПодвал.УстановитьПараметр("Период",СсылкаНаОбъект.Дата);
ЗапросПодвал.УстановитьПараметр("Должность",Справочники.ДолжностиОрганизаций.НайтиПоРеквизиту("Наименование","Генеральний директор"));
    РезПодвал = ЗапросПодвал.Выполнить().Выбрать();
Пока РезПодвал.Следующий() Цикл
ОблПодвал.Параметры.ГенДиректор = РезПодвал.Сотрудник;

КонецЦикла;
ЗапросПодвал.УстановитьПараметр("Должность",Справочники.ДолжностиОрганизаций.НайтиПоРеквизиту("Наименование","Перший заступник генерального директора"));
РезПодвал2 = ЗапросПодвал.Выполнить().Выбрать();
Пока РезПодвал.Следующий() Цикл
ОблПодвал.Параметры.ПервыйЗам = РезПодвал.Сотрудник;
КонецЦикла;
    ТабДок.Вывести(ОблПодвал);
Возврат ТабДок;
КонецФункции

Golickoff

Чему равна переменная "СсылкаНаОбъект"?
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

alex0402

может там буковки перемешаны латиница и кириллица?
Спасибо за Сказать спасибо

AsadRoman

А где видно что СсылкаНаОбъект присвоено значение?

oleg-x

Цитата: alex0402 от 20 сен 2017, 08:17
может там буковки перемешаны латиница и кириллица?
ВводСведенийОПлановыхНачисленияхРаботниковОрганизацийОсновныеНачисления. Ссылка = <<?>>& Ccылка
Скорее всего, так как одно слово подчеркивает красным (параметр), а в запросе нет.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

bustabar

В общем. Закомментировал установку параметра. Убрал строку с ним из запроса. Запустил отладку. Закрыл отладку. Раскомментировал. Запустил. Ругаться перестало. А СсылкаНаОбьект присваивается автоматически при запуске внешней обработки(по идее, прошу не ругаться, я 1С первый раз в глаза увидел 2 недели назад).

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск