Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 20:07

Расшифровка в отчете по регистратору!Help!

Автор Vladislav, 13 сен 2017, 11:08

0 Пользователей и 1 гость просматривают эту тему.

Vladislav

Здравствуйте, уважаемые программисты!
Помогите реализовать в отчете при кликании на ячейку метод -Расшифровать..чтобы открывался соответствующий документ сразу, а не через окно выбора - Регистратор..
Пока что у меня такой параметр в принципе недоступен..
Сам отчет формирует - Нач.остаток, приход,расход, конечный остаток с группировкой по номенклатуре и периоду..и отбором по номенклатуре и складу
Прикрепляю базу(Отчеты-Обороты1)

alex0402

Цитата: Vladislav от 13 сен 2017, 11:08Сам отчет формирует - Нач.остаток, приход,расход, конечный остаток с группировкой по номенклатуре и периоду..и отбором по номенклатуре и складу

а как без расшифровать, если есть группировка и в одну строку будет включены результаты нескольких документов.
Спасибо за Сказать спасибо

Vladislav

Цитата: alex0402 от 13 сен 2017, 11:11
Цитата: Vladislav от 13 сен 2017, 11:08Сам отчет формирует - Нач.остаток, приход,расход, конечный остаток с группировкой по номенклатуре и периоду..и отбором по номенклатуре и складу

а как без расшифровать, если есть группировка и в одну строку будет включены результаты нескольких документов.

Ну вот если нажать на цифру, то это действие недоступно.а доступно только на самой номенклатуре, или периоде

alex0402

Цитата: Vladislav от 13 сен 2017, 11:27Ну вот если нажать на цифру, то это действие недоступно.а доступно только на самой номенклатуре, или периоде
цифру какую? должно быть доступно только на оборотах (приход или расход).
Спасибо за Сказать спасибо

oleg-x

ЦитироватьПомогите реализовать в отчете при кликании на ячейку метод -Расшифровать..чтобы открывался соответствующий документ сразу, а не через окно выбора - Регистратор..
Придется помучится.
У тебя есть табличное поле, у поля есть разные события. Нужно программно прописать расшифровку в одном из событие табличного поля.
Не делал, но теоретически возможно :dfbbdrfb:
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Vladislav

Цитата: alex0402 от 13 сен 2017, 12:05
Цитата: Vladislav от 13 сен 2017, 11:27Ну вот если нажать на цифру, то это действие недоступно.а доступно только на самой номенклатуре, или периоде
цифру какую? должно быть доступно только на оборотах (приход или расход).

Ну да, так и есть, цифры только там..вот я и хочу чтобы мне по ней выходила расшифровка

Добавлено: 13 сен 2017, 19:46


Цитата: oleg-x от 13 сен 2017, 13:45
ЦитироватьПомогите реализовать в отчете при кликании на ячейку метод -Расшифровать..чтобы открывался соответствующий документ сразу, а не через окно выбора - Регистратор..
Придется помучится.
У тебя есть табличное поле, у поля есть разные события. Нужно программно прописать расшифровку в одном из событие табличного поля.
Не делал, но теоретически возможно :dfbbdrfb:
есть процедура..но вылазит ошибка - СхемаКомпоновкиДанных - неопределенная переменная
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
Перем ВыполненноеДействие;

    // Запретим стандартную обработку расшифровки
    СтандартнаяОбработка = Ложь;

    // Создадим и инициализируем обработчик расшифровки
    ОбработкаРасшифровки = Новый ОбработкаРасшифровкиКомпоновкиДанных(ДанныеРасшифровки, Новый ИсточникДоступныхНастроекКомпоновкиДанных(СхемаКомпоновкиДанных));

    // Осуществим выбор действия расшифровки пользователем
    Настройки = ОбработкаРасшифровки.Выполнить(Расшифровка, ВыполненноеДействие);

    Если Настройки <> Неопределено Тогда
        // Пользователь выбрал действие, для которого нужно менять настройки

        Если ВыполненноеДействие = ДействиеОбработкиРасшифровкиКомпоновкиДанных.Упорядочить Тогда
            // Если требется упорядочить - упорядочим в текущем отчете
            КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
            СформироватьОтчет();

        Иначе
            // При других действиях - создадим новый отчет, откроем форму, сформируем отчет в ней
            Отчет = Отчеты[Метаданные().Имя].Создать();
            Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
            Форма = Отчет.ПолучитьФорму();
            Форма.СформироватьОтчет();
            Форма.Открыть();

        КонецЕсли;

    КонецЕсли;
КонецПроцедуры


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск