Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 23:20

Запрет на изменения реализации

Автор sitash, 25 авг 2017, 12:11

0 Пользователей и 1 гость просматривают эту тему.

sitash

Добрый день.
Можно поставить "запрет на изменения" только документов реализации и счет фактуры. 1С 8,2.
Например - можно ли написать условия при проведение документа реализации сравнить дату и если ЛОЖЬ тогда не проводить (а проводить можно только Монопольном режиме для тех ситуаций когда вчерашная или позавчерашная реализация меняется).
Заранее всем спасибо.

oleg-x

Можно все, в процедуре перед записью пропишите отказ, если нет необходимых условий для проведения документа.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

sitash

Цитата: oleg-x от 25 авг 2017, 12:34
Можно все, в процедуре перед записью пропишите отказ, если нет необходимых условий для проведения документа.
я могу зайти конфигуратор и изменить но не могу написать программку. если сможете помогите. спасибо

oleg-x

Цитата: sitash от 25 авг 2017, 12:41
Цитата: oleg-x от 25 авг 2017, 12:34
Можно все, в процедуре перед записью пропишите отказ, если нет необходимых условий для проведения документа.
я могу зайти конфигуратор и изменить но не могу написать программку. если сможете помогите. спасибо
По опыту. лучше обратитесь в раздел фрилан, опишите условие при которых не должны проводится документы и за небольшую денежку Вам все сделают.

А код будет выглядеть так примерно:

Процедура ПередЗаписью(отказ)
//Здесь стандартный код 1С
    НетправНаПроведениеДокумента(отказ);
КонецПроцедуры

Процедура НетправНаПроведениеДокумента(отказ)
    //здесь пишем условие при котором пользователю разрешается провести документ
    Если НачалоДня(Дата) < НачалоДня(ТекущаяДата) Тогда
        Если НЕ ПользователюРазрешеноПроводит Тогда
            отказ=истина;
        Конецесли;
    КонецЕсли
КонецПроцедуры
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск