Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 июн 2022, 08:37

Метод Найти работает для многомерных массивов?

Автор nature2002, 13 мар 2011, 01:24

0 Пользователей и 1 гость просматривают эту тему.

nature2002

что-то у меня не работает в двухмерном... Ищу строку с наименованием, чтобы по ней получить ссылку. В массиве есть строки(Наименование номенклатуры) и ссылки(ссылка на нее).


Группы = Новый Массив;

Пока ...
Группа = Справочники.Номенклатура.СоздатьГруппу();
Группа.Наименование = Чтение.Значение;
Родитель = Неопределено;
Позиция = Группы.Найти(Структура.Родитель);
Если НЕ(Позиция=Неопределено) тогда Родитель = Группы[Позиция][1]; КонецЕсли;
Группа.Родитель = ?(Родитель=Неопределено,Справочники.Номенклатура.ПустаяСсылка(),Родитель);
Группа.Записать();
Массив = Новый Массив(2);
Массив.Добавить(Группа.Наименование);
Массив.Добавить(Группа.Ссылка);
Группы.Добавить(Массив);
КонецЦикла;

nature2002

что-то у меня не работает в двухмерном... Ищу строку с наименованием, чтобы по ней получить ссылку. В массиве есть строки(Наименование номенклатуры) и ссылки(ссылка на нее).

Группы = Новый Массив;

Пока....

Группа = Справочники.Номенклатура.СоздатьГруппу();
Группа.Наименование = Чтение.Значение;
Родитель = Неопределено;
Позиция = Группы.Найти(Структура.Родитель);
Если НЕ(Позиция=Неопределено) тогда Родитель = Группы[Позиция][1]; КонецЕсли;
Группа.Родитель = ?(Родитель=Неопределено,Справочники.Номенклатура.ПустаяСсылка(),Родитель);
Группа.Записать();
Массив = Новый Массив(2);
Массив.Добавить(Группа.Наименование);
Массив.Добавить(Группа.Ссылка);
Группы.Добавить(Массив);

КонецЦикла;

nature2002

заменила таблицей. все работает. вопрос решен.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск