Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мар 2023, 19:17

Ошибка при обновлении информационной базы

Автор doll, 01 янв 2017, 14:04

0 Пользователей и 1 гость просматривают эту тему.

doll

При установке модуля обмена с Битрикс на 1С предприятие 8.3.8.1784 Конфигурация УТ 11.2 делала по инструкции отладку с параметром "ЗапуститьОбновлениеИнформационнойБазы". Программа не дает завершить обновление по причине ошибки: "Ошибка в схеме компоновки данных
по причине:
Ошибка получения информации набора данных
по причине:
Ошибка в запросе набора данных
по причине:
{(58, 2)}: Несовместимые типы "ВЫБОР"
<<?>>ВЫБОР"

Данная ошибка в Общем модуле. Длительность операции. 376 строка. Вот текст (376 строка отмечена цифрой):

Функция ЗаданиеВыполнено(Знач ИдентификаторЗадания) Экспорт
   
   Задание = НайтиЗаданиеПоИдентификатору(ИдентификаторЗадания);
   
   Если Задание <> Неопределено
      И Задание.Состояние = СостояниеФоновогоЗадания.Активно Тогда
      Возврат Ложь;
   КонецЕсли;
   
   ОперацияНеВыполнена = Истина;
   ПоказатьПолныйТекстОшибки = Ложь;
   Если Задание = Неопределено Тогда
      ЗаписьЖурналаРегистрации(НСтр("ru = 'Длительные операции.Фоновое задание не найдено'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
         УровеньЖурналаРегистрации.Ошибка, , , Строка(ИдентификаторЗадания));
   Иначе
      Если Задание.Состояние = СостояниеФоновогоЗадания.ЗавершеноАварийно Тогда
         ОшибкаЗадания = Задание.ИнформацияОбОшибке;
         Если ОшибкаЗадания <> Неопределено Тогда
            ПоказатьПолныйТекстОшибки = Истина;
         КонецЕсли;
      ИначеЕсли Задание.Состояние = СостояниеФоновогоЗадания.Отменено Тогда
         ЗаписьЖурналаРегистрации(
            НСтр("ru = 'Длительные операции.Фоновое задание отменено администратором'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
            УровеньЖурналаРегистрации.Ошибка,
            ,
            ,
            НСтр("ru = 'Задание завершилось с неизвестной ошибкой.'"));
      Иначе
         Возврат Истина;
      КонецЕсли;
   КонецЕсли;
   
   Если ПоказатьПолныйТекстОшибки Тогда
       ТекстОшибки = КраткоеПредставлениеОшибки(ПричинаОшибки(Задание.ИнформацияОбОшибке));
376   ВызватьИсключение (ТекстОшибки);
   ИначеЕсли ОперацияНеВыполнена Тогда
      ВызватьИсключение(НСтр("ru = 'Не удалось выполнить данную операцию.
                            |Подробности см. в Журнале регистрации.'"));
   КонецЕсли;
   
КонецФункции

#КонецОбласти

Поиск родных

Цитата: doll от 01 янв 2017, 14:04
При установке модуля обмена с Битрикс на 1С предприятие 8.3.8.1784 Конфигурация УТ 11.2 делала по инструкции отладку с параметром "ЗапуститьОбновлениеИнформационнойБазы". Программа не дает завершить обновление по причине ошибки: "Ошибка в схеме компоновки данных
по причине:
Много раз и устанавливал-обновлял модуль Битрикса для УТ11.2 и саму УТ11.2 с уже установленным модулем, но я не понимаю, о чём Вы пишите. Дайте ссылку на инструкцию, они все  открытом доступе и привяжите её цитаты к Вашей ситуации
**************************************
Нужна помощь в поиске родных! https://forum-1c.ru/index.php?topic=79683.msg231850#msg231850
НАЙДЕННЫЕ нашей командой родные https://forum-1c.ru/index.php?topic=79555.0
Заявки на поиск делать сообщением в Телеграм-группе

doll

Цитата: Геннадий ОбьГЭС от 01 янв 2017, 15:22
Цитата: doll от 01 янв 2017, 14:04
При установке модуля обмена с Битрикс на 1С предприятие 8.3.8.1784 Конфигурация УТ 11.2 делала по инструкции отладку с параметром "ЗапуститьОбновлениеИнформационнойБазы". Программа не дает завершить обновление по причине ошибки: "Ошибка в схеме компоновки данных
по причине:
Много раз и устанавливал-обновлял модуль Битрикса для УТ11.2 и саму УТ11.2 с уже установленным модулем, но я не понимаю, о чём Вы пишите. Дайте ссылку на инструкцию, они все  открытом доступе и привяжите её цитаты к Вашей ситуации

https://dev.1c-bitrix.ru/learning/course/?COURSE_ID=42&LESSON_ID=7184
Предпоследний и последний шаг по данной инструкции:

Выполните обновление данных в базе 1С. Для этого откройте Сервис > Параметры. На вкладке Запуск 1С: Предприятия укажите параметр запуска ЗапуститьОбновлениеИнформационнойБазы и нажмите Ок:

После запуска отладки начинает идет процесс обновления ИБ, но на 91% процесс останавливается и выдает ошибку в Общем модуле. Длительность операции. 376 строка:

"Ошибка в схеме компоновки данных
по причине:
Ошибка получения информации набора данных
по причине:
Ошибка в запросе набора данных
по причине:
{(58, 2)}: Несовместимые типы "ВЫБОР"
<<?>>ВЫБОР"

Привожу код функции где прописана строка:

Функция ЗаданиеВыполнено(Знач ИдентификаторЗадания) Экспорт
   
   Задание = НайтиЗаданиеПоИдентификатору(ИдентификаторЗадания);
   
   Если Задание <> Неопределено
      И Задание.Состояние = СостояниеФоновогоЗадания.Активно Тогда
      Возврат Ложь;
   КонецЕсли;
   
   ОперацияНеВыполнена = Истина;
   ПоказатьПолныйТекстОшибки = Ложь;
   Если Задание = Неопределено Тогда
      ЗаписьЖурналаРегистрации(НСтр("ru = 'Длительные операции.Фоновое задание не найдено'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
         УровеньЖурналаРегистрации.Ошибка, , , Строка(ИдентификаторЗадания));
   Иначе
      Если Задание.Состояние = СостояниеФоновогоЗадания.ЗавершеноАварийно Тогда
         ОшибкаЗадания = Задание.ИнформацияОбОшибке;
         Если ОшибкаЗадания <> Неопределено Тогда
            ПоказатьПолныйТекстОшибки = Истина;
         КонецЕсли;
      ИначеЕсли Задание.Состояние = СостояниеФоновогоЗадания.Отменено Тогда
         ЗаписьЖурналаРегистрации(
            НСтр("ru = 'Длительные операции.Фоновое задание отменено администратором'", ОбщегоНазначенияКлиентСервер.КодОсновногоЯзыка()),
            УровеньЖурналаРегистрации.Ошибка,
            ,
            ,
            НСтр("ru = 'Задание завершилось с неизвестной ошибкой.'"));
      Иначе
         Возврат Истина;
      КонецЕсли;
   КонецЕсли;
   
   Если ПоказатьПолныйТекстОшибки Тогда
       ТекстОшибки = КраткоеПредставлениеОшибки(ПричинаОшибки(Задание.ИнформацияОбОшибке));
:^454^:   ВызватьИсключение (ТекстОшибки);
   ИначеЕсли ОперацияНеВыполнена Тогда
      ВызватьИсключение(НСтр("ru = 'Не удалось выполнить данную операцию.
                            |Подробности см. в Журнале регистрации.'"));
   КонецЕсли;
   
КонецФункции

#КонецОбласти










Поиск родных

Столько много букв, а самого главного не пишите - какова полная версия УТ 11.2 и версия модуля Битрикс, который Вы устанавливаете:
Соответствие версий и дат УТ 11.2 и Модули Битрикс (ссылки для скачивания)

Битрикс - Скачать дополнительные модули для 1С

Контакты

1С-Битрикс http://www.1c-bitrix.ru Общие вопросы info@1c-bitrix.ru Приобретение и лицензирование продуктов: sales@1c-bitrix.ru Маркетинг/мероприятия/PR marketing@1c-bitrix.ru Партнерская программа partners@1c-bitrix.ru Мы работаем с 10:00 до 19:00 по московскому времени. Офис в Москве +7 (495) 229-14-41 Офис в Москве 127287 Россия Московская область Москва 2-я Хуторская улица дом 38А строение 9 Офис в Калининграде +7 (4012) 51-05-64 Офис в Калининграде 236001 Россия Калининградская область Калининград Московский проспект 261 Офис в Киеве ukraine@1c-bitrix.ru Телефон в Киеве +3 (8044)221-55-33 Офис в Киеве 01033 Украина Калининградская область Киев улица Шота Руставели 39/41 офис 1507


**************************************
Нужна помощь в поиске родных! https://forum-1c.ru/index.php?topic=79683.msg231850#msg231850
НАЙДЕННЫЕ нашей командой родные https://forum-1c.ru/index.php?topic=79555.0
Заявки на поиск делать сообщением в Телеграм-группе

doll

Цитата: Геннадий ОбьГЭС от 01 янв 2017, 20:44
Столько много букв, а самого главного не пишите - какова полная версия УТ 11.2 и версия модуля Битрикс, который Вы устанавливаете:
Соответствие версий и дат УТ 11.2 и Модули Битрикс (ссылки для скачивания)

УТ 11.2.3.168. Версия модуля 6.0.3.4

Поиск родных

Цитата: doll от 01 янв 2017, 21:49
УТ 11.2.3.168. Версия модуля 6.0.3.4
И? Вы смотрели на соответствие версий?
В соответствии со ссылкой, которую я дал выше, самый актуальный/последний модуль Битрикс 6.0.3.4 сделан под УТ версии 11.2.3.108 и он понятия не имеет, что там могло появиться в УТ последующих версий

В лучшем случае Вы устанавливаете модуль Битрикс на УТ 11.2.3.108
**************************************
Нужна помощь в поиске родных! https://forum-1c.ru/index.php?topic=79683.msg231850#msg231850
НАЙДЕННЫЕ нашей командой родные https://forum-1c.ru/index.php?topic=79555.0
Заявки на поиск делать сообщением в Телеграм-группе

doll

Цитата: Геннадий ОбьГЭС от 01 янв 2017, 22:41
Цитата: doll от 01 янв 2017, 21:49
УТ 11.2.3.168. Версия модуля 6.0.3.4
И? Вы смотрели на соответствие версий?
В соответствии со ссылкой, которую я дал выше, самый актуальный/последний модуль Битрикс 6.0.3.4 сделан под УТ версии 11.2.3.108 и он понятия не имеет, что там могло появиться в УТ последующих версий

В лучшем случае Вы устанавливаете модуль Битрикс на УТ 11.2.3.108



Ошибка была при установке модуля! Не надо было менять режим совместимости. Спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск