Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2022, 10:13

Отправка сканов из папки привязанных к кодам серий номенклатуры из Реализауия товаров и услуг

Автор Гайдар, 06 мая 2016, 16:02

0 Пользователей и 1 гость просматривают эту тему.

Гайдар


Доброго времени суток!

Процедура ниже ... Хочу отправить файлов привязанных к кодам серий номенклатуры и документа Реализация, но вложение не добавляется.
Сообщение.Вложения.Добавить(Новый ДвоичныеДанные(ВыбФайл),ВыбФайл.Имя);
по причине:
Файл не обнаружен 'Файл'

Что подскажете?


Процедура ОсновныеДействияФормыПечатьPDF(Кнопка)
     МассивФайлов = Новый Массив;
     Путь = "D:\Сканы TIFF\";
     ТипФайла = ".Tif";
Для каждого стр из Товары цикл
         
Если ЭтотОбъект.Контрагент.Код = "Ц00002520" Тогда
ВыбФайл = Новый Файл(Путь+стр.СерияНоменклатуры.Код+ТипФайла);
Если ВыбФайл.Существует() Тогда
   сообщить(ВыбФайл.Имя);
Почта = Новый ИнтернетПочта;
Попытка
Почта.Подключиться(ПолучитьПрофиль());
Исключение
Сообщить(ОписаниеОшибки()+ " " + "Возможно нет связи, проверьте интернет и повторите для данного склада");
Возврат;
КонецПопытки;

Сообщение = Новый ИнтернетПочтовоеСообщение;
Сообщение.Вложения.Добавить(Новый ДвоичныеДанные(ВыбФайл),ВыбФайл.Имя);
Сообщение.Отправитель = "zayavkitp@mail.ru";
Сообщение.ИмяОтправителя = "Справки";
ПочтовыеАдреса = Сообщение.Получатели;

ПочтовыйАдрес = ПочтовыеАдреса.Добавить();
ПочтовыйАдрес.Адрес = "abasov.gaydar@mail.ru";


Сообщение.Тема ="Справки";

ИнтернетТекстПочтовогоСообщения = Сообщение.Тексты.Добавить();
ИнтернетТекстПочтовогоСообщения.Текст = "Скачивайте файлы справок и скопируйте в необходиму папку";
ИнтернетТекстПочтовогоСообщения.ТипТекста = ТипТекстаПочтовогоСообщения.ПростойТекст;

Попытка
// Пытаемся послать письмо
Почта.Послать(Сообщение);
Исключение
Сообщить(ОписаниеОшибки()+ " " + "Возможно нет связи, проверьте интернет и повторите для данного склада");
Возврат;
КонецПопытки;
// отключение
Сообщить("Справки отправлены по почте");
Почта.Отключиться();
КонецЕсли;
КонецЕсли;



КонецЦикла;

КонецПроцедуры

Rasty

Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Гайдар

Цитата: Rasty от 06 мая 2016, 16:24
так вложение добавляются по пути файла, зачем двоичные данные?

Пробовал и так Сообщение.Вложения.Добавить(ВыбФайл);

{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(3951)}: Ошибка при вызове метода контекста (Добавить)
Сообщение.Вложения.Добавить(ВыбФайл);
по причине:
Несоответствие типов (параметр номер '1')

Kironten

Цитата: Гайдар от 06 мая 2016, 16:36
Цитата: Rasty от 06 мая 2016, 16:24
так вложение добавляются по пути файла, зачем двоичные данные?

Пробовал и так Сообщение.Вложения.Добавить(ВыбФайл);

{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(3951)}: Ошибка при вызове метода контекста (Добавить)
Сообщение.Вложения.Добавить(ВыбФайл);
по причине:
Несоответствие типов (параметр номер '1')

Потому как ВыбФайл у вас тип "Файл", а передавать надо тип "Строка".

Гайдар

Цитата: Kironten от 06 мая 2016, 16:38
Цитата: Гайдар от 06 мая 2016, 16:36
Цитата: Rasty от 06 мая 2016, 16:24
так вложение добавляются по пути файла, зачем двоичные данные?

Пробовал и так Сообщение.Вложения.Добавить(ВыбФайл);

{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(3951)}: Ошибка при вызове метода контекста (Добавить)
Сообщение.Вложения.Добавить(ВыбФайл);
по причине:
Несоответствие типов (параметр номер '1')

Потому как ВыбФайл у вас тип "Файл", а передавать надо тип "Строка".

Сообщение.Вложения.Добавить() - напишите эту строку кода как правильно , я начинающий , не пойму

Kironten

Цитата: Гайдар от 06 мая 2016, 16:47
Цитата: Kironten от 06 мая 2016, 16:38
Цитата: Гайдар от 06 мая 2016, 16:36
Цитата: Rasty от 06 мая 2016, 16:24
так вложение добавляются по пути файла, зачем двоичные данные?

Пробовал и так Сообщение.Вложения.Добавить(ВыбФайл);

{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(3951)}: Ошибка при вызове метода контекста (Добавить)
Сообщение.Вложения.Добавить(ВыбФайл);
по причине:
Несоответствие типов (параметр номер '1')

Потому как ВыбФайл у вас тип "Файл", а передавать надо тип "Строка".

Сообщение.Вложения.Добавить() - напишите эту строку кода как правильно , я начинающий , не пойму
Все у нас тут начинающие :btbzdb:
Сообщение.Вложения.Добавить(ВыбФайл.ПолноеИмя);

Гайдар

Цитата: Kironten от 06 мая 2016, 16:51
Цитата: Гайдар от 06 мая 2016, 16:47
Цитата: Kironten от 06 мая 2016, 16:38
Цитата: Гайдар от 06 мая 2016, 16:36
Цитата: Rasty от 06 мая 2016, 16:24
так вложение добавляются по пути файла, зачем двоичные данные?

Пробовал и так Сообщение.Вложения.Добавить(ВыбФайл);

{Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(3951)}: Ошибка при вызове метода контекста (Добавить)
Сообщение.Вложения.Добавить(ВыбФайл);
по причине:
Несоответствие типов (параметр номер '1')

Потому как ВыбФайл у вас тип "Файл", а передавать надо тип "Строка".

Сообщение.Вложения.Добавить() - напишите эту строку кода как правильно , я начинающий , не пойму
Все у нас тут начинающие :btbzdb:
Сообщение.Вложения.Добавить(ВыбФайл.ПолноеИмя);
Рабтает :zebzdr: СПАСИБО:ooifh:    было лучще если все файлы по документу отправляла одним письмом:(

Rasty

Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Гайдар


Rasty

Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск