Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 фев 2023, 18:23

Добавление номенклатуры в ТЧ документа

Автор mashencev_anton, 16 апр 2015, 13:22

0 Пользователей и 1 гость просматривают эту тему.

mashencev_anton

Конфа Ут 10.3. док ЗаказПоставщику. по нажатию кнопки(команда не стандартная) выполняется запрос и в Тч добавляется новая номенклатура, но автоматически почему-то не заполняются колонки, например: артикул, ед.изм, НДС....т.е чтобы эти данные заполнились, необходимо перевыбрать эту номенклатуру..как это исправить??

cska-fanat-kz

Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

mashencev_anton

Цитата: cska-fanat-kz от 16 апр 2015, 13:25
анализируйте код кнопки

а что тут анализировать то?
&НаКлиенте
Процедура ТоварыПодЗаказ(Команда)

ТоварыПодЗаказНаСервере();

КонецПроцедуры

&НаСервере
Процедура ТоварыПодЗаказНаСервере()

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаказПодКлиентаТовары.Номенклатура
|ИЗ
| Документ.ЗаказПодКлиента.Товары КАК ЗаказПодКлиентаТовары
|ГДЕ
| ЗаказПодКлиентаТовары.Поставщик = &Поставщик
| И ЗаказПодКлиентаТовары.Ссылка.Проведен
| И НЕ ЗаказПодКлиентаТовары.Ссылка.ПометкаУдаления
| И ЗаказПодКлиентаТовары.СтатусЗаказаТовара = ЗНАЧЕНИЕ(Перечисление.СтатусТовараПодЗаказ.Утвержден)";

Запрос.УстановитьПараметр("Поставщик", Объект.Контрагент);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
ЗаполнитьЗначенияСвойств(Объект.Товары.Добавить(),ВыборкаДетальныеЗаписи);
КонецЦикла;


КонецПроцедуры

cska-fanat-kz

Цитата: mashencev_anton от 16 апр 2015, 13:29
ВЫБРАТЬ
| ЗаказПодКлиентаТовары.Номенклатура

собака порылась вот тут

Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

mashencev_anton

Цитата: cska-fanat-kz от 16 апр 2015, 13:34
Цитата: mashencev_anton от 16 апр 2015, 13:29
ВЫБРАТЬ
| ЗаказПодКлиентаТовары.Номенклатура

собака порылась вот тут
что там может быть не так?? Выразить()?

cska-fanat-kz

у меня больше как "весенний авитаминоз" нет вариантов :dfbsdfbsdf: :trhregerhg:

после
ВЫБРАТЬ
| ЗаказПодКлиентаТовары.Номенклатура

добавьте хотя бы
| ЗаказПодКлиентаТовары.Номенклатура.Артикул КАК Артикул

и вуаля? Артикул заполнился?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

mashencev_anton

Цитата: cska-fanat-kz от 16 апр 2015, 14:00
у меня больше как "весенний авитаминоз" нет вариантов :dfbsdfbsdf: :trhregerhg:

после
ВЫБРАТЬ
| ЗаказПодКлиентаТовары.Номенклатура

добавьте хотя бы
| ЗаказПодКлиентаТовары.Номенклатура.Артикул КАК Артикул

и вуаля? Артикул заполнился?
ну зря Вы так сразу про авитоминоз))))))):D:D:D
Вы когда добавляете Номенклатуру,вручную, в документ то такие данные как Артикул, ед.хрн, НДС, они подтягиваются автоматически....... Вот о чём я

cska-fanat-kz

да понял я.
вы на последний мой вопрос ответьте...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

mashencev_anton

Цитата: cska-fanat-kz от 16 апр 2015, 14:08
да понял я.
вы на последний мой вопрос ответьте...
Артикул заполнился а что толку??? всё равно всё по прежниму.. а если я еще по мимо номенклатуры и артикула буду добавлять количество и цену, то сумму мне он все равно не посчитает, нужно будет перевыбрать тоогда количество

cska-fanat-kz

вот вы скачете! :thwrt:

сперва с реквизитами номенклатуры разберитесь.
вобщем доделывайте запрос...

расчет сумм и всего остального можно передрать с НоменклатураПриИзменении()
и с соответствующем корректировкой поместить вот сюда:
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ЗаполнитьЗначенияСвойств(Объект.Товары.Добавить(),ВыборкаДетальныеЗаписи);
--->>>
    КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск