Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 авг 2022, 20:09

Реализация товара на основании заказа клиента - Преобразование значения к типу Булево не может быть выполнено

Автор NBomzh, 10 фев 2015, 20:16

0 Пользователей и 1 гость просматривают эту тему.

NBomzh

День добрый, форумчане!
Поставил УТ11, копаюсь, настраиваю... Есть проблема:
При создании Реализации Товаров И Услуг без заказа все проходит гладко, товар списывается.
При создании Заказа Клиента все проходит гладко - все записывается, проводится и т.д.
При создании на основании Заказа Клиента Приходного Кассового Ордера, Акта или Поступления безнала все проходит гладко...
Но вот стоит попробовать создать на основании Заказа Клиента Реализацию - выскакивает окно с надписью "Преобразование значения к типу Булево не может быть выполнено".

По настройкам вкратце - все делаю "галочками" через клиента. Есть несколько организаций ("галка" стоит), несколько складов (то же самое), никаких ордеров и статусов, нет контроля остатков, но есть перемещения между своими организациями.

Кто-нибудь, хелп ми плиз, если есть возможность, знания и желание... На все дополнительные вопросы готов ответить. На данный момент это последнее, что отделяет нас от запуска программы в дело...

дфтын

Помог? Нажми - Спасибо :)
skype: Soprov1C

NBomzh

Цитата: дфтын от 10 фев 2015, 20:44
вы скопируйте полностью ошибку сюда
Так в том-то и дело... Просто окошечко с этой надписью и кнопка "Ок". Ни слова больше...:dfbbdrfb:

Прошу прощения, ехать надо... Буду только завтра часов в 10-11 МСК...
Добавлено: 11 фев 2015, 10:49


Я снова в онлайне, готов отвечать на вопросы. Буду рад любой помощи.
Добавлено: 11 фев 2015, 12:18


Нашел, что конфигуратор пишет по этому поводу:
{ОбщийМодуль.МногооборотнаяТараСервер.Модуль(200)}: Преобразование значения к типу Булево не может быть выполнено

vitasw


NBomzh

Цитата: vitasw от 11 фев 2015, 13:17
Так приведите, что там в строке 200 пишется.
Приведу полностью кусок кода:
// Рассчитывает дату возврата многооборотной тары по условиям соглашения
//
// Параметры:
// Объект - ДокументОбъект - Документ, для которого считается срок возврата тары
// СрокВозвратаМногооборотнойТары - Число - Срок возврата многооборотной тары в днях
// РассчитыватьДатуВозвратаТарыПоКалендарю - Булево - Определяет вариант расчета даты: по всем дня или по основному календарю предприятия
// Календарь - СправочникСсылка.ПроизводственныеКалендари - Определяет календарь возврата тары
//
// Возвращаемое значение:
// Дата
//
Функция РассчитатьДатуВозвратаМногооборотнойТары(Знач Объект,
                                             Знач СрокВозвратаМногооборотнойТары,
                                             Знач РассчитыватьДатуВозвратаТарыПоКалендарю,
                                             Знач Календарь) Экспорт

ОдинДень = 86400;

ДатаОтсчетаВозвратаТары = ОпределитьДатуОтсчетаВозвратаТары(Объект);

Если Не ЗначениеЗаполнено(ДатаОтсчетаВозвратаТары) Тогда
ДатаОтсчетаВозвратаТары = ТекущаяДата();
КонецЕсли;

Если РассчитыватьДатуВозвратаТарыПоКалендарю И ЗначениеЗаполнено(Календарь) Тогда
ДатаВозвратаМногооборотнойТары = КалендарныеГрафики.ПолучитьДатуПоКалендарю(
Календарь,
ДатаОтсчетаВозвратаТары,
СрокВозвратаМногооборотнойТары);
Иначе
ДатаВозвратаМногооборотнойТары = ДатаОтсчетаВозвратаТары + ОдинДень * СрокВозвратаМногооборотнойТары;
КонецЕсли;

Возврат НачалоДня(ДатаВозвратаМногооборотнойТары);

КонецФункции

Строка 200 - это там, где "Если РассчитыватьДатуВозвратаТарыПоКалендарю И ЗначениеЗаполнено(Календарь) Тогда"


апд:
Получается, что РассчитыватьДатуВозвратаТарыПоКалендарю не существует, т.к. использование возвратной тары отключено или Календарь не существует, тогда и результат ЗначениеЗаполнено() = NULL? Так?
Добавлено: 11 фев 2015, 15:26


Удалил "РассчитыватьДатуВозвратаТарыПоКалендарю ИЛИ" и все заработало. Правда, цены почему-то не переносит из заявки в накладную, но это совсем другая история...

Понимаю, что сделал не совсем (или совсем не) правильно, но это косяк, если прога обращается к функциям, которые должны игнорироваться, т.к. в настройках они отключены. Это жрет лишние ресурсы.

Быть может, правильнее как-то по другому сделать?

vitasw

ЗначениеЗаполнено(Календарь) - в принципе не может выдавать ошибку
РассчитыватьДатуВозвратаТарыПоКалендарю - ошибка тут. Скорее всего данная переменная не определена - похоже на ошибку разработчика. Я бы копал то место где эта переменная определяется.

NBomzh

Нашел решение, правда, на другом форуме:
http://www.forum.mista.ru/topic.php?id=676599
Будем теперь сами решать...

Всем спасибо за ответы!
Добавлено: 12 фев 2015, 12:21


Цитата: NBomzh от 11 фев 2015, 18:05
Будем теперь сами решать...
Мое решение (вдруг, кому полезно будет):
- Включил использование типовых соглашений
- Создал заказ клиента
- Создал новое типовое соглашение, в котором в графике оплат проставил 100% кредит, а также НДС в зависимости от организации-продавца
- Сохранил и провел документ
- Отключил использование соглашений
- Удалил заказ клиента

Все стало работать. Видимо, после первого раза где-то что-то прописалось, инициализировалось...
Вот как-то так...

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск