Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 23:19

Получить реквизит элемента

Автор tornado, 05 авг 2014, 22:08

0 Пользователей и 1 гость просматривают эту тему.

tornado

Здравствуйте.
   Есть две справочника Клиенты и Контрагенты. Один из реквизита Справочника "Клиенты" "ГдеРаботает" задано тип СправочникСсылка.Контрагенты.
   Есть документ Наряд. В документе выбираем Клиента и следующая поля "Место работы" должно получит данные из реквизита Справочник Клиенты.

Создал процедуру ПриИзменение. Через Запрос получил нужные данные на переменную СТР, но не знаю как присвоит к элементу документа "Место работы" Подскажите пожалуйста!
--------------------------------------
&НаКлиенте
Процедура КлиентПриИзменении(Элемент)
   НайтиМестоРаботы();
КонецПроцедуры

&НаСервере
Процедура НайтиМестоРаботы()
            
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   Справочник.Клиенты.Наименование,
      |   Справочник.Клиенты.ГдеРаботает
      |ИЗ
      |   Справочник.Клиенты"
;
   РезультатЗапроса = Запрос.Выполнить();
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      СТР = ВыборкаДетальныеЗаписи.ГдеРаботает;
   КонецЦикла;

                   
КонецПроцедуры



tornado

Если
Объект.Ссылка.Фирма = ВыборкаДетальныеЗаписи.ГдеРаботает
То выдает ошибку "Поле объекта недоступно для записи (Фирма)"
                   

Zlobnyi_Troll

А просто "Объект.Фирма = ВыборкаДетальныеЗаписи.ГдеРаботает;" не работает? :)

Чем ссылка от объекта, кстати, отличается, читали? :)

И почему в запросе выбираются все элементы справочника "Клиенты"?

tornado

Цитата: Zlobnyi_Troll от 06 авг 2014, 00:20
А просто "Объект.Фирма = ВыборкаДетальныеЗаписи.ГдеРаботает;" не работает? :)

Чем ссылка от объекта, кстати, отличается, читали? :)

И почему в запросе выбираются все элементы справочника "Клиенты"?


В запросе я просто взял две элемента. А вообще если заработает, мне нужно несколько элемента получить и присвоит. Подскажите если знаете, что надо исправить.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск