Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 июн 2022, 08:28

Спрятать от менеджера в табличной части кассу / Вывести определенную кассу

Автор avangarddv, 05 мая 2014, 09:41

0 Пользователей и 1 гость просматривают эту тему.

avangarddv

ДД!

Имеется 1C 8.2. УНФ

В перемещении денег, в табличной части, необходимо ограничить вывод Касс. А именно, что бы у одного менеджера была возможность видеть в табличной части только одну кассу - Кассу Москвы.

Что делаю:
1. Сделал роль - Кассы Москвы.
2. Написал условие выбора касс:

&НаКлиенте
Процедура ПриОткрытии(Отказ)
Если РольКассыМосквы() Тогда
ОтборКасса=ПолучитьКассаМосква();
КонецЕсли;
КонецПроцедуры


&НаСервере
Функция РольКассыМосквы()
Возврат РольДоступна("КассыМосквы");
конецФункции

&НаСервере
Функция ПолучитьКассаМосква()
Возврат Справочники.Кассы.НайтиПоНаименованию("Касса Москва");
КонецФункции


Но что то видимо не-то делаю.. ? Может есть другой способ вывода нужных данных в табличной части?

cska-fanat-kz

Для программного добавления отбора в динамический список надо юзать условное оформление.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

avangarddv

Не подскажите каким образом составить там условие?

Т.е. зашел в раздел - Условное оформление. Далее ставлю условие - Список.Касса = Отбор.Касса

В оформляемые полях задаю - Список.Касса.

Никакого вывода, не понимаю как задать Отбор.Касса = Нужная мне касса.

Список.Касса - это как раз тот реквизит, в табличной части, где выводятся кассы.


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск