Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 мая 2022, 20:53

Ввод на основании программно в 8,2

Автор 1cka, 25 мар 2014, 14:05

0 Пользователей и 1 гость просматривают эту тему.

1cka

Пробую Сделать ввод на основании...

На форме документа (ДокИсходный) создала кнопку:
Процедура ДействияФормыЗаказТР(Кнопка)

  НовДок = Документы.ДокНовый.СоздатьДокумент();
  НовДок.Заполнить(Ссылка);
  НовДок.ПолучитьФорму().Открыть();
   
КонецПроцедуры


В свойствах ВВод на основании документа ДокНовый указала что вводится на основании ДокИсходный
и в модуле ДокНовый прописала
Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
  Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ДокИсходный") Тогда
  ///
  КонецЕсли;
КонецПроцедуры


Вопрос - что не так я делаю? сейчас код отрабатывает без ошибок, но ничего не происходит. Нажимаешь на кнопку, а реакции никакой.

MuI_I_Ika

Так у вас же здесь ничего не написано:

Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ДокИсходный") Тогда
  ///
  КонецЕсли;

1cka

Цитата: MuI_I_Ika от 26 мар 2014, 01:22
Так у вас же здесь ничего не написано:

Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ДокИсходный") Тогда
  ///
  КонецЕсли;

Я просто не стала писать...:nhsrm:

Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.ДокИсходный") Тогда
//*** заполним шапочку документа
Контрагент = ДанныеЗаполнения.Контрагент;
Организация = ДанныеЗаполнения.Организация;
КонецЕсли;

Сейчас я хотела, ХОТЯБЫ, чтобы открылась форма нового документа,а потом уж буду пробывать делать заполнение. Должна ведь форма открываться?

MuI_I_Ika

Попробуйте вместо этого: НовДок.ПолучитьФорму().Открыть();
сделать так:

Форма = НовДок.ПолучитьФорму();
Форма.Открыть();

1cka

Цитата: MuI_I_Ika от 26 мар 2014, 09:46
Попробуйте вместо этого: НовДок.ПолучитьФорму().Открыть();
сделать так:

Форма = НовДок.ПолучитьФорму();
Форма.Открыть();
к сожалению не помагает...:dfbsdfbsdf:
в процедуру входит и все! ничего не понимаю...
Действие по кнопке должно мне только открыть форму другого пустого документа, правильно ведь?
Может ли быть загвоздка в том, что в Исходном документе я изменила настройку поддержки с "Не редактируется" на "Редактируется с сохранением поддержки" - для самого документа и для формы документа.???
А ДокументНовый - это самописный документ.? Может из-за этого они никак не подружатся?

MuI_I_Ika

Может просто воспользоваться стандартным механизмом ввода на основании. Через кнопочку ввода на основании. Почему она не используется?

1cka

Цитата: MuI_I_Ika от 26 мар 2014, 16:37
Может просто воспользоваться стандартным механизмом ввода на основании. Через кнопочку ввода на основании. Почему она не используется?
:) да вот... так и делаю... но нужно чтобы еще и кнопочка была прямо у пользователя чуть ли не "на носу" - чтобы ее было вИИИИдно!

MuI_I_Ika

Ну, ок. Формы обычные или управляемые?

1cka


MuI_I_Ika

Ну в обычных формах должно все работать.

Вот на этой строке документ заполняется?

НовДок.Заполнить(Ссылка);

Надо поотлаживать что там происходит.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск