Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 23:13

1c 8.2 конфигурация салон красоты

Автор x2ermak, 02 фев 2014, 08:30

0 Пользователей и 1 гость просматривают эту тему.

x2ermak

Здравствуйте.
Помогите разобраться с конфигурацией 1с салон красоты

суть вопроса в следующем:

При создании "графика работы сотрудников" в окне "отмеченные дни" пусто, хотя в рабочей конфигурации должна быть таблица.
Я так подозреваю, что я не заполнил какое-то поле.... может кто сталкивался с подобной проблемой.

Если в "графике работы" нажимаю сохранить, возникает следующая ошибка :

{Обработка.ГрафикРаботыСотрудников.Форма.Форма.Форма(530)}: Индекс находится за границами массива
    НаборЗаписейРегистра.Отбор.СтруктурнаяЕдиница.Установить(ГрафикПериодовРаботы[0].СтруктурнаяЕдиница);


В конфигураторе это выглядит так:

Процедура СохранитьИзменения(Период)
   
   НаборЗаписейРегистра = РегистрыСведений.ВремяРаботыСотрудниковПлан.СоздатьНаборЗаписей();
   НаборЗаписейРегистра.Отбор.СтруктурнаяЕдиница.Установить(ГрафикПериодовРаботы[0].СтруктурнаяЕдиница);
   НаборЗаписейРегистра.Отбор.МесяцОтбор.Установить(НачалоМесяца(ГрафикПериодовРаботы[0].Период));
   НаборЗаписейРегистра.Прочитать();
   ТаблицаЗаписейРегистра = НаборЗаписейРегистра.Выгрузить();
   
   // Удаляем период удаленные из графика
   Для Каждого СтрокаРегистра Из ТаблицаЗаписейРегистра Цикл
      СтруктураЗаписи = Новый Структура("СтруктурнаяЕдиница, Сотрудник", СтрокаРегистра.СтруктурнаяЕдиница, СтрокаРегистра.Сотрудник);
      МассивСтрокГрафика = ГрафикПериодовРаботы.НайтиСтроки(СтруктураЗаписи);
      СтрокаРегистраАктуальна = Ложь;
      Для Каждого СтрокаГрафика Из МассивСтрокГрафика Цикл
         Для Каждого ПериодДняГрафика Из СтрокаГрафика["День" + День(СтрокаРегистра.ДатаВремяНачала)] Цикл
            Если ПериодДняГрафика.Значение.НачалоСмены = СтрокаРегистра.ДатаВремяНачала И ПериодДняГрафика.Значение.ОкончаниеСмены = СтрокаРегистра.ДатаВремяОкончания Тогда
               СтрокаРегистраАктуальна = Истина;
            КонецЕсли;
         КонецЦикла;
      КонецЦикла;
      Если СтрокаРегистраАктуальна = Ложь Тогда
         МенеджерЗаписиРегистра = РегистрыСведений.ВремяРаботыСотрудниковПлан.СоздатьМенеджерЗаписи();
         ЗаполнитьЗначенияСвойств(МенеджерЗаписиРегистра, СтрокаРегистра);
         МенеджерЗаписиРегистра.Удалить();
      КонецЕсли;      
   КонецЦикла;
   
   // Удаляем периоды добавленные в график
   Для Каждого СтрокаГрафика Из ГрафикПериодовРаботы Цикл
      Для ДеньГрафика = 1 По 31 Цикл
         Для Каждого ПериодДняГрафика Из СтрокаГрафика["День" + ДеньГрафика] Цикл
            СтруктураЗаписи = Новый Структура("СтруктурнаяЕдиница, Сотрудник, ДатаВремяНачала, ДатаВремяОкончания", СтрокаГрафика.СтруктурнаяЕдиница, СтрокаГрафика.Сотрудник, ПериодДняГрафика.Значение.НачалоСмены, ПериодДняГрафика.Значение.ОкончаниеСмены);
            Если ТаблицаЗаписейРегистра.НайтиСтроки(СтруктураЗаписи).Количество() = 0 Тогда
               МенеджерЗаписиРегистра = РегистрыСведений.ВремяРаботыСотрудниковПлан.СоздатьМенеджерЗаписи();
               МенеджерЗаписиРегистра.СтруктурнаяЕдиница = СтрокаГрафика.СтруктурнаяЕдиница;
               МенеджерЗаписиРегистра.Сотрудник = СтрокаГрафика.Сотрудник;
               МенеджерЗаписиРегистра.МесяцОтбор = СтрокаГрафика.Период;
               МенеджерЗаписиРегистра.ДатаВремяНачала = ПериодДняГрафика.Значение.НачалоСмены;
               МенеджерЗаписиРегистра.ДатаВремяОкончания = ПериодДняГрафика.Значение.ОкончаниеСмены;
               МенеджерЗаписиРегистра.Минуты = (ПериодДняГрафика.Значение.ОкончаниеСмены - ПериодДняГрафика.Значение.НачалоСмены) / 60;
               МенеджерЗаписиРегистра.Записать();
            КонецЕсли;
         КонецЦикла;
      КонецЦикла;
   КонецЦикла;
   
   МодифицированностьГрафикаРаботы = Ложь;




LordWizard

Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

x2ermak


LordWizard

Если обновление конфигурации - одно из последних, то думаю что с этой платформой эта конфигурация работать не будет нормально.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

x2ermak

Обновил платформу на 8.2.19.83... такая-же ситуация. Может дело в конфигурации ??:(

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск