Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2022, 11:08

Получить номер без префикса

Автор MuI_I_Ika, 10 дек 2013, 00:14

0 Пользователей и 1 гость просматривают эту тему.

MuI_I_Ika


Очень часто при разработке собственных решений на 1с требуется получать номера документов или коды справочников без префикса. Это нужно, например, для вывода номера на печать.


Однако средствами платформы произвести такую трансформацию не получается. Поэтому каждый разработчик сам для себя решает данную задачу. В данном примере я предлагаю вычислять префикс путем отделения в номере числовой части от буквенной:


Функция ПолучитьНомерБезПрефикса(Номер)

Результат = Номер;

Для к = 1 по СтрДлина(Номер) Цикл

Символ = Сред(Номер,к,1);

Попытка
ЧислоСимвола = Число(Символ);
Исключение
ЧислоСимвола = Неопределено;
КонецПопытки;

Если ЧислоСимвола <> Неопределено Тогда

Результат = Сред(Номер,к);
Прервать;

КонецЕсли;

КонецЦикла;

Возврат Результат;

КонецФункции

Теги:

Похожие темы (4)

Рейтинг@Mail.ru Rambler's Top100

Поиск