Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 июл 2022, 22:35

Создание Подбора (Ошибка)

Автор Kostik2013, 03 апр 2013, 14:54

0 Пользователей и 1 гость просматривают эту тему.

Kostik2013

Не могу найти ошибку,подскажите,что не так сделал?


{ОбщаяФорма.ФормаПодбора.Форма(4,57)}: Переменная не определена (Группа)
   Список.Параметры.УстановитьЗначениеПараметра("Группа", <<?>>Группа); (Проверка: Сервер)
{ОбщаяФорма.ФормаПодбора.Форма(9,58)}: Переменная не определена (Группа)
   Список.Параметры.УстановитьЗначениеПараметра( "Группа", <<?>>Группа); (Проверка: Тонкий клиент)



&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   Список.Параметры.УстановитьЗначениеПараметра("Группа", Группа);
КонецПроцедуры

&НаКлиенте
Процедура ОбновитьСписок()
   Список.Параметры.УстановитьЗначениеПараметра( "Группа", Группа);
КонецПроцедуры

&НаКлиенте
Процедура ДеревоВыборЗначения(Элемент,Значение, СтандартнаяОбработка)
   Группа = Значение;
   ОбновитьСписок();
КонецПроцедуры


&НаКлиенте
Процедура ДеревоОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
   Группа =ВыбранноеЗначение;
   ОбновитьСписок();
КонецПроцедуры

&НаКлиенте
Процедура ДеревоПередРазворачиванием(Элемент, Строка, Отказ)
   Группа =Строка;
   ОбновитьСписок();
КонецПроцедуры

&НаКлиенте
Процедура ДеревоПередСворачиванием(Элемент, Строка, Отказ)
   Группа = Строка;
   ОбновитьСписок();
КонецПроцедуры

&НаКлиенте
Процедура ДеревоПриСменеТекущегоРодителя(Элемент)
   Группа =Элемент.Родитель;
   ОбновитьСписок();
КонецПроцедуры

&НаКлиенте
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
   ТекущаяСтрока = Элемент.ТекущиеДанные;
   НоваяСтрока =Отобранные.Добавить();
   НоваяСтрока.Номенклатура =ТекущаяСтрока.Ссылка;
   НоваяСтрока.Цена =ТекущаяСтрока.Цена;
КонецПроцедуры


&НаКлиенте
Процедура ОК(Команда)
        Закрыть(ЗаписатьВХранилище());
   КонецПроцедуры
   
   &НаСервере
Функция ЗаписатьВХранилище()
        Возврат ПоместитьВоВременноеХранилище(Отобранные.Выгрузить());
КонецФункции


Yura063

Он же вам пишет, что у списка нет параметра Группа!!!
Помогли, отблагодари!

Kostik2013

Цитата: Yura063 от 03 апр 2013, 15:01
Он же вам пишет, что у списка нет параметра Группа!!!

а куда же его впихнуть можно?

Yura063

Какая база, что за документ и что хотите получить в итоге?
Чему у вас равно Группа?
Помогли, отблагодари!

Kostik2013

Цитата: Yura063 от 03 апр 2013, 17:00
Какая база, что за документ и что хотите получить в итоге?
Чему у вас равно Группа?

1С:Предприятие 8.2 (8.2.15.310)
Делаю подбор в ПриходнойНакладной с Ценой из РегистраСведений.ЦеныРозничные

Делаю по подобию этого : http://alsproject.ru/publ/primery/sozdanie_formy_formavybora/4-1-0-15

Yura063

Одно из двух: 1) Не видет ваш запрос.
              2) Проверьте соответствует ли параметр в запросе с параметром которые вы передаете.
Добавлено: 03 апр 2013, 17:20


Попробуйте проверить, добавьте:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    [b]Группа = //Присвойте значение группы[/b]
        Список.Параметры.УстановитьЗначениеПараметра("Группа",Группа);
КонецПроцедуры

Добавлено: 03 апр 2013, 17:23


Скорее всего при создании на сервере вы к параметру группа не присвоили значение
Помогли, отблагодари!

Kostik2013

Цитата: Yura063 от 03 апр 2013, 17:17
Одно из двух: 1) Не видет ваш запрос.
              2) Проверьте соответствует ли параметр в запросе с параметром которые вы передаете.
Добавлено: 03 апр 2013, 17:20


Попробуйте проверить, добавьте:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    [b]Группа = //Присвойте значение группы[/b]
        Список.Параметры.УстановитьЗначениеПараметра("Группа",Группа);
КонецПроцедуры

Добавлено: 03 апр 2013, 17:23


Скорее всего при создании на сервере вы к параметру группа не присвоили значение

Спасибо!!

Dethmontt

Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Kostik2013

Все давно  сделал)Спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск