Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2022, 10:56

Автоматический расчет суммы из количества товаров и цены.

Автор superjet, 28 ноя 2012, 11:26

0 Пользователей и 1 гость просматривают эту тему.

superjet

Перепутал темы.Это для версии 8.2 а не 7.7
Вопрос-если создана процедура РассчетСуммы .Зачем ссылку на нее прописывать в остальных процедурах
Процедура СписокТоваровКоличествоПриИзменении(Элемент)
Процедура СписокТоваровЦенаПриИзменении(Элемент)

Ведь она с виду может сама брать данные из Стр=Элементы.СписокТоваров.ТекущиеДанные;
То есть в этих данных уже находиться цена и количество.А потом умножать их и записывать данные в сумму.
Но если не прописать РассчетСуммы ();
то цена не рассчитываеться.То есть логику понять.А то я начинаю только изучать программирование.

&НаКлиенте
Процедура СписокТоваровКоличествоПриИзменении(Элемент)
РассчетСуммы ();
КонецПроцедуры

&НаКлиенте
Процедура СписокТоваровЦенаПриИзменении(Элемент)
   РассчетСуммы()

КонецПроцедуры




&НаКлиенте
Процедура РассчетСуммы()
   Стр=Элементы.СписокТоваров.ТекущиеДанные;
   Стр.Сумма = Стр.Цена*Стр.Количество ;
КонецПроцедуры

mixqn

логика такая, что система должна как-то понимать, в какой момент ту или иную процедуру выполнять. если все процедуры будут непрерывно перезапускаться и все время работать, боюсь даже представить что будет... :D
короче говоря, вызов процедуры в конкретном месте кода означает, что именно тут она должна выполниться, например при изменении количества или цены в вашем примере.

Yura063

Возьмите Радченко "Практическое пособие разработчика" там такой пример очень хорошо описан! да и книгу прочитать будет вам полезно!
Помогли, отблагодари!

markgenuine

в радченко нужно глядеть!!+1
А так, ничего сложного нет в этом;)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск