Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2022, 10:32

Не могу открыть обработку

Автор help, 26 авг 2011, 08:34

0 Пользователей и 1 гость просматривают эту тему.

help

Скачал с официального сайта форму 328.00? далее добавил обработку в конфи в дерево обработки. Через предприятия не могу открыть, пишет "Обработка предназначена для служебного использования"
Как быть?

has

Открыть обрабокту в конфигураторе, найти это сообщение и запрет на открытие и убрать их

help

Вот что я нашел! Если я уберу, боюсь на что то повлияет это, или нет?
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
   
   Если НЕ ЗначениеЗаполнено(ДокументДляВыгрузки) Тогда
      Предупреждение("Обработка предназначена для служебного использования");
      Отказ = Истина;
      Возврат;
   КонецЕсли;

   РевизияВыгрузки = "v2_r11";
   ЭлементыФормы.ВерсияФНО.Значение = "328.00."+СтрЗаменить(РевизияВыгрузки,"_",".");
КонецПроцедуры

has

Ну закоментируй, я не знаю что за обработка и на что повлияет

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
 
  //Если НЕ ЗначениеЗаполнено(ДокументДляВыгрузки) Тогда
  //   Предупреждение("Обработка предназначена для служебного использования");
  //   Отказ = Истина;
  //   Возврат;
  //КонецЕсли;

  РевизияВыгрузки = "v2_r11";
  ЭлементыФормы.ВерсияФНО.Значение = "328.00."+СтрЗаменить(РевизияВыгрузки,"_",".");
КонецПроцедуры

Вобще я так понимаю что она не предназначена для открывания интерактивно, с ней по другому как-то работать нада

help

В общем получилось следующее. Обработка выходит через Регламентированный отчетность, а там он все равно показывает ошибку!!!

has

Какую ошибку то? Вобще в описании обработки не сказано как с ней работать чтоли?

help

Есть специальный документ "ДляВыгрузки", вот с этого и надо начинать! пока не заполнишь и при нажатий на кнопку выгрузить в XML открывается эта обработка

has

Ну и открывай из документа ее. Или я что-то не понимаю?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск