Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 21:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка при попытке удаления. БД 1С 8.2  (Прочитано 3153 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kvax

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-18
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!
Столкнулся со следующей проблемой, имеются справочники:
 - Справочник.Вакансии
 - Справочник. Резюме
Необходимо удалять из них элементы, которые хранятся более определенного времени.

При попытке выполнить обработку выдает сообщение об ошибке:

 - При попытке удаления Вакансии:
{Обработка.ЧисткаБазы.Форма.Форма.Форма(22)}: Метод объекта не обнаружен (Удалить)
Выборка.Удалить(0);

 - При попытке удаления Резюме:
{Обработка.ЧисткаБазы.Форма.Форма.Форма(37)}: Метод объекта не обнаружен (ПометкаУдаления)
Выборка.Ссылка.ПометкаУдаления();

Буду очень признателен, в решении данной проблемы.

Код обработки прилагается.




Процедура ЧисткаБазы(Фл_СтарыеВакансии, Фл_СтарыеРезюме)

КолСтарыхВакансий = 0;

Выборка = Справочники.Вакансии.Выбрать();
Пока Выборка.Следующий() Цикл
Если (Выборка.ДатаРазмещения+ Выборка.СрокХранения) < ТекущаяДата() Тогда
Сообщить ("Вакансия № " + Выборка.Код);
КолСтарыхВакансий = КолСтарыхВакансий+1;

Если Фл_СтарыеВакансии Тогда
Выборка.Удалить(0);
КонецЕсли;
Иначе
Сообщить("Просроченных вакансий - нет!");
КонецЕсли;
КонецЦикла;
                                     
КолСтарыхРезюме = 0;
Выборка = Справочники.Резюме.Выбрать();
Пока Выборка.Следующий() Цикл
Если (Выборка.ДатаРазмещения+ Выборка.СрокХранения) < ТекущаяДата() Тогда
Сообщить ("Резюме № " + Выборка.Код);
КолСтарыхВакансий = КолСтарыхВакансий+1;

Если Фл_СтарыеРезюме Тогда
Выборка.Ссылка.ПометкаУдаления();
КонецЕсли;
Иначе
Сообщить("Просроченных резюме - нет!");
КонецЕсли;
КонецЦикла;


КонецПроцедуры


Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
во первых по 1 проблеме, уж надо писать
Выборка.ПолучитьОбъект().Удалить();

но я так не рекомендую, лишь потому, что вы можете не учесть наличие ссылок. лучше делать так:

Объект = Выборка.ПолучитьОбъект();
Объект.ПометкаУдаления = Истина;
Объект.Записать();

Тем самым мы после сможем удалить элементы при помощи стандартной обработки удаления.

второй случай, метода пометка удаления не существует. пользуемся также как и показано выше!
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн Kvax

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-18
  • Сайт: 
  • Профессия: Ученик 1С
Огромное спасибо за помощь, прислушаюсь к вашей рекомендации!!!


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4542
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6100
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4207
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8523
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8570
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 265
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal