Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Май 2018, 12:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Прямая печать на принтер  (Прочитано 5506 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн trilogia

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-18
  • Сайт: 
  • Профессия: Программист 1С
Добрый день!
Помоги решить проблемку с групповой печатью сразу на принтер без вывод диалогового окна.
Код находится ниже. В Таб.ПараметрыСтраницы(1,,,,,,,,,1,0,); прописывал имя принтера, но диалоговое окно все равно вываливается.

Процедура Сформировать()   
   Таб = СоздатьОбъект("Таблица");
   Док = СоздатьОбъект("Документ.Договор");
   Таб.ИсходнаяТаблица("фДоговор");     
   Док.ВыбратьДокументы(НачДата,КонДата);
   Пока Док.Получитьдокумент()=1 цикл
      НомерДок = Док.НомерДок;
      ДатаДок = Док.ДатаДок;
      Контрагент = Док.Контрагент.ПолноеНаименование;
      ЮрАдрес = Док.Контрагент.ЮридическийАдрес;
      ИНН = Док.Контрагент.ИНН;
      КПП = Док.Контрагент.КПП;
      Таб.ВывестиСекцию("Шапка");   
      Таб.ПараметрыСтраницы(1,,,,,,,,,1,0,);
      Таб.КоличествоЭкземпляров(2);
      Таб.Напечатать(0);
   КонецЦикла;
КонецПроцедуры


Оффлайн trilogia

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-18
  • Сайт: 
  • Профессия: Программист 1С
Добился открытия печатных форм в предпосмотр.
код такой
Процедура Печать(Док, Устройство=0, КолвоКопий=1)       
   СтатусВозврата = 0;   
   НомерДок = Док.НомерДок;
   ДатаДок = Док.ДатаДок;
   Контрагент = Док.Контрагент.ПолноеНаименование;
   ЮрАдрес = Док.Контрагент.ЮридическийАдрес;
   ИНН = Док.Контрагент.ИНН;
   КПП = Док.Контрагент.КПП;
   
   Таб = СоздатьОбъект("Таблица");
   Таб.ИсходнаяТаблица("Печать");
   Таб.ВывестиСекцию("Шапка");
   Таб.Опции(0,0,0,0);     
   Таб.ПараметрыСтраницы(1,,,,,,,,,1,0,);
   Таб.ТолькоПросмотр(1);
   Таб.Показать("Печать Договор","");
КонецПроцедуры       


Процедура ПриОткрытии()
Если ПустоеЗначение(Форма.Параметр) = 0 Тогда
Док      = Форма.Параметр.Получить("Контекст");
Устройство = Форма.Параметр.Получить("Устройство");
КолвоКопий = Форма.Параметр.Получить("КоличествоКопий");
Печать(Док, Устройство, КолвоКопий);
Статусвозврата(0);
Возврат;
КонецЕсли;
КонецПроцедуры






//*******************************************
Процедура Сформировать()   
   Таб = СоздатьОбъект("Таблица");
   Док = СоздатьОбъект("Документ.Договор");
   СписокПараметров = СоздатьОбъект("СписокЗначений");
   СписокПараметров.Установить("Команда","ПечатьНаПринтер");
   СписокПараметров.Установить("КолЭкз",1);
   Док.ВыбратьДокументы(НачДата,КонДата);
   Пока Док.Получитьдокумент()=1 цикл
      Печать(Док);
   КонецЦикла;
КонецПроцедуры
           
 но вот как сделать чтобы все автоматом шло на печать?

Оффлайн trilogia

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-18
  • Сайт: 
  • Профессия: Программист 1С
Тему можно считать закрытой. Разобрался.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
alex0402
74 Сообщений
oleg-x
67 Сообщений
AIFrame AIFrame
60 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
39 Сообщений
Анюта17
33 Сообщений
KOI8-R
32 Сообщений
trialex3
30 Сообщений

* Кто онлайн

  • Точка Гостей: 768
  • Точка Скрытых: 0
  • Точка Пользователей: 16
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal