Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 23:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнить табличную часть документа  (Прочитано 13645 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн WolfBlack

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-12
  • Сайт: 
  • Профессия: Программист 1С
Люди добрые, подскажите пожалуйста как заполнить табличную часть документа из справочника Сотрудники


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Сформулируйте вопрос точнее. Сейчас не вопрос,а каша.

Оффлайн WolfBlack

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-12
  • Сайт: 
  • Профессия: Программист 1С
Сформулируйте вопрос точнее. Сейчас не вопрос,а каша.
Мне нужно в документ "Табель1" с табличной частью "ТабличнаяЧасть1" в колонку "Сотрудник" по нажатию кнопки "Заполнить" заполнить ФИО из справочника "Сотрудники" с иерархической формой списка, которая содержит в себе Уволенных и Основных, нужно заполнить из Основных

Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
напишите запрос, в нем условие.
загрузите в табличную часть таким кодом:
ТабличнаяЧасть1.Загрузить(Запрос.Выполнить.Выгрузить());
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн WolfBlack

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-12
  • Сайт: 
  • Профессия: Программист 1С
напишите запрос, в нем условие.
загрузите в табличную часть таким кодом:
ТабличнаяЧасть1.Загрузить(Запрос.Выполнить.Выгрузить());
Это как-то сложновато... Нельзя ли просто как-то циклом пробежаться по справочнику и так же циклом заполнить табличную часть документа?

Оффлайн WolfBlack

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-12
  • Сайт: 
  • Профессия: Программист 1С
Например как-то так:
Таб=ЭлементыФормы.ТабличноеПоле1;
   Таб.очистить();
   Если Таб.КоличествоСтрок() =0 тогда
      Сотр= СоздатьОбъект(Справочники.Сотрудники);
      Сотр.ВыбратьЭлементы();
      Пока Сотр.ПолучитьЭлемены()=1 Цикл
         Таб.НоваяСтрока();
      КонецЦикла;
   КонецЕсли;   
Только эта байда не работает.. :)

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Это как-то сложновато... Нельзя ли просто как-то циклом пробежаться по справочнику и так же циклом заполнить табличную часть документа?
Почему сложновато? В чем смысл цикла в данном случае?

Оффлайн WolfBlack

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-12
  • Сайт: 
  • Профессия: Программист 1С
Это как-то сложновато... Нельзя ли просто как-то циклом пробежаться по справочнику и так же циклом заполнить табличную часть документа?
Почему сложновато? В чем смысл цикла в данном случае?
Потому что я только начал изучать 1с и до запросов ещё не добрался... только до циклов... потому и хочу проверить как это работает...

Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
Например как-то так:
Таб=ЭлементыФормы.ТабличноеПоле1;
   Таб.очистить();
   Если Таб.КоличествоСтрок() =0 тогда
      Сотр= СоздатьОбъект(Справочники.Сотрудники);
      Сотр.ВыбратьЭлементы();
      Пока Сотр.ПолучитьЭлемены()=1 Цикл
         Таб.НоваяСтрока();
      КонецЦикла;
   КонецЕсли;   
Только эта байда не работает.. :)

это код 7ки!
в 8. такая конструкция
Выборка = Справочники.Сотрудники.Выбрать();

Пока Выборка.Следующий() Цикл
//заполняйте строку ТЧ
КонецЦикла;
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Оффлайн WolfBlack

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-12
  • Сайт: 
  • Профессия: Программист 1С
это код 7ки!
в 8. такая конструкция
Выборка = Справочники.Сотрудники.Выбрать();

Пока Выборка.Следующий() Цикл
//заполняйте строку ТЧ
КонецЦикла;
Пиушу так:
Выборка=Справочники.Сотрудники.Выбрать();
СтрокаТабличнойЧасти=ЭлементыФормы.ТабличноеПоле1.ТекущиеДанные;
Пока Выборка.Следующий()цикл
СтрокаТабличнойЧасти.Сотрудник=(Что сюда написать?);
КонецЦикла;
Или я вообще не правильно мыслю?


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4473
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15931
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 629
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7744
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
41 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 217
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal