Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 11:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как выбить пользователей из базы в 1С  (Прочитано 4968 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн макс

  • ****
  • Сообщений: 305
  • РЕПУТАЦИЯ: 10
  • КПД: 3%
  • Регистрация: 2010-06-15
  • Сайт: 
Есть обработка для работы в клиент-серверном варианте, вот ее код;
ПодстрокиСтрокиСоединения = РазложитьСтрокуВМассивПодстрок(СтрокаСоединенияИнформационнойБазы(),";");


СтрокаСоединения = СтрокаСоединенияИнформационнойБазы();
ЭтоСоединение = НомерСоединенияИнформационнойБазы();
Сервер    = НСтр(СтрокаСоединения, "File");
База = НСтр(СтрокаСоединения, "Ref");
КОМ = Новый COMОбъект("V82.COMConnector");

Агент = КОМ.ConnectAgent("IRA");
Кластеры = Агент.GetClusters();
Кластер = Кластеры.GetValue(0);
Агент.Authenticate(Кластер, "", "");
РабочиеПроцессы = Агент.GetWorkingProcesses(Кластер);
//Процесс = РабочиеПроцессы.GetValue(0);
Для Каждого Процесс Из РабочиеПроцессы Цикл
СтрокаСоединенияРП = Процесс.HostName + ":" + Формат(Процесс.MainPort, "ЧГ = ");
СоединениеРП = КОМ.ConnectWorkingProcess(СтрокаСоединенияРП);
СоединениеРП.AddAuthentication(Пользователь, Пароль);
ОписаниеИБ = СоединениеРП.CreateInfoBaseInfo();
ОписаниеИБ.Name = База;
Соединения = СоединениеРП.GetInfoBaseConnections(ОписаниеИБ);
Для Каждого Соединение Из Соединения Цикл
Если Соединение.AppID = "COMConsole" Тогда
Продолжить;
КонецЕсли;
Если НомерСоединения <> 0 Тогда
Если Соединение.ConnID = НомерСоединения Тогда
СоединениеРП.Disconnect(Соединение);
КонецЕсли;
ИначеЕсли Соединение.ConnID <> ЭтоСоединение Тогда
СоединениеРП.Disconnect(Соединение);
КонецЕсли;
КонецЦикла;
КонецЦикла;
КОМ = Неопределено;

мне нужно выбить пользователей в файловом варианте, как это можно сделать? где эти все кластеры, рабочие процессы в файловом варианте


Оффлайн Шурыгин Иван Сергеевич

  • забей на все....
  • ****
  • Сообщений: 330
  • РЕПУТАЦИЯ: 82
  • КПД: 25%
  • забей на все!
  • Регистрация: 2011-05-23
  • Сайт: 
  • Профессия: Программист 8.1
вам обязательно выбивать всех пользователей через ком соединение?
второе. просто убирайте строки про кластеры, оставляйте лишь поиск соединений, и также дисконекты
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================


Теги:
 

Можете помочь написать обработку которая сможет делать реализацию списывая поступления из другой базы или ссылаясь на них? просто одна компания покупает другая продает этот товар и чтобы вторая компания не смогла продать больше чем есть у первой? 1с 8.2 2

Автор Юлия АндреевнаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 748
Последний ответ 13 Ноя 2016, 19:25
от BuhRust
Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9202
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Как перенести конфу базы данных на новую конфу?

Автор dim3740Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 11261
Последний ответ 23 Авг 2010, 15:41
от mohock
восстановить учет после после уреза базы

Автор NarimanРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 3863
Последний ответ 16 Июн 2011, 15:02
от Nariman
Восстановление испорченной базы данных 1С [chdbfl.exe] [chdbfl]

Автор MuI_I_IkaРаздел Администрирование 1с

Ответов: 3
Просмотров: 28211
Последний ответ 04 Дек 2012, 13:13
от greenLiss

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 824
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal