Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 13:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с печатной формой пожалуйста  (Прочитано 5598 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн drapik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 8.1
Вот собственно модуль:
Функция Печать() Экспорт
   Запрос = Новый Запрос;
   Запрос.УстановитьПараметр("ТекущийДокумент", СсылкаНаОбъект.Ссылка);
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ИнвентаризацияТоваровНаСкладе.Организация,
   |   ИнвентаризацияТоваровНаСкладе.Дата,
   |   ИнвентаризацияТоваровНаСкладе.ОтветственноеЛицо.Наименование КАК ФизЛицо,
   |   ИнвентаризацияТоваровНаСкладе.Товары.(
   |      НомерСтроки КАК Номер,
   |      Количество КАК Количество,
   |      Номенклатура.НаименованиеПолное КАК ТоварНаименование,
   |      Номенклатура.Код КАК ТоварКод,
   |      Цена КАК Цена
   |   ),
   |   ПоступлениеТоваровУслуг.Дата КАК ДатаПриход
   |ИЗ
   |   Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
   |      ЛЕВОЕ СОЕДИНЕНИЕ Документ.ИнвентаризацияТоваровНаСкладе КАК ИнвентаризацияТоваровНаСкладе
   |      ПО (ИнвентаризацияТоваровНаСкладе.Товары.Номенклатура = ПоступлениеТоваровУслуг.Товары.Номенклатура)
   |ГДЕ
   |   ИнвентаризацияТоваровНаСкладе.Ссылка = &ТекущийДокумент
   |
   |УПОРЯДОЧИТЬ ПО
   |   ИнвентаризацияТоваровНаСкладе.Товары.НомерСтроки";
   Шапка = Запрос.Выполнить().Выбрать();
   Шапка.Следующий();
    ВыборкаСтрокТовары = Шапка.Товары.Выбрать();
   ТабДокумент = Новый ТабличныйДокумент;
   ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ИнвентаризацияТоваровНаСкладе_ИНВ3";
   Макет       = ПолучитьМакет("ИНВ3");

   // Выводим шапку накладной
   ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
   ОбластьМакета.Параметры.Заполнить(Шапка);
   ОбластьМакета.Параметры.ПредставлениеОрганизации = Шапка.Организация;
   ОбластьМакета.Параметры.Дата                   = Шапка.Дата;
   ОбластьМакета.Параметры.ФизЛицо                = Шапка.ФизЛицо;
   ТабДокумент.Вывести(ОбластьМакета);
   
   // Выводим заголовок таблицы
   ЗаголовокТаблицы = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
   ТабДокумент.Вывести(ЗаголовокТаблицы);

   КоличествоСтрок = ВыборкаСтрокТовары.Количество();

   // Выводим многострочную часть докмента
   ВыборкаСтрокТовары = Шапка.Товары.Выбрать();
   ОбластьМакета = Макет.ПолучитьОбласть("Строка");
   Пока ВыборкаСтрокТовары.Следующий() Цикл
        ОбластьМакета.Параметры.Заполнить(ВыборкаСтрокТовары);
      ОбластьМакета.Параметры.ТоварНаименование = ВыборкаСтрокТовары.ТоварНаименование;
      ОбластьМакета.Параметры.ДатаПриход = Шапка.ДатаПриход;
        ТабДокумент.Вывести(ОбластьМакета);
   КонецЦикла;   
      // Зададим параметры макета
   ТабДокумент.ПолеСверху = 0;
   ТабДокумент.ПолеСлева  = 0;
   ТабДокумент.ПолеСнизу  = 0;
   ТабДокумент.ПолеСправа = 0;
   ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;

   Возврат ТабДокумент;

КонецФункции // ПечатьКарточкиМЦ()

Печатная форма карточки из документа инвентаризации по МОЛ. В печатной форме ДатаПриход ставится одинаковая дата документа, хотя приход товаров был по разным документам и разным датам поступления. Как ДатаПриход связать с Товары, чтобы выбиралась дата поступления для каждого товара? Заранее благодарен!!!


Оффлайн drapik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 8.1
Да, и еще вдогонку, как оставить только дату, а то отображается и дата и время документа поступления.

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
Если я правильно понимаю, то вы печатаете форму из документа ИнвентаризацияТоваровНаСкладе
Каждый товар приходуется отдельным документом?
Чтобы вывести только дату необходимо сделать Формат вывода
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Да, и еще вдогонку, как оставить только дату, а то отображается и дата и время документа поступления.
ОбластьМакета.Параметры.Дата = Формат(Шапка.Дата, "ДЛФ=Д");

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Печатная форма карточки из документа инвентаризации по МОЛ. В печатной форме ДатаПриход ставится одинаковая дата документа, хотя приход товаров был по разным документам и разным датам поступления. Как ДатаПриход связать с Товары, чтобы выбиралась дата поступления для каждого товара? Заранее благодарен!!!
Надо выбирать табличную часть документа инвентаризация и левым соединением с таб. частью поступления по номенклатуре.

Оффлайн drapik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 8.1
to Андрей Федотов: Да, каждый документ приходуется отдельным документом, т.е. даты должны быть разные для каждой строки номенклатуры, но у меня ставится одна и та же дата, которая берется с документа поступления одного из товаров. Has, спасибо, время убрал.

Оффлайн drapik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 8.1
Печатная форма карточки из документа инвентаризации по МОЛ. В печатной форме ДатаПриход ставится одинаковая дата документа, хотя приход товаров был по разным документам и разным датам поступления. Как ДатаПриход связать с Товары, чтобы выбиралась дата поступления для каждого товара? Заранее благодарен!!!
Надо выбирать табличную часть документа инвентаризация и левым соединением с таб. частью поступления по номенклатуре.
Так в запросе так и стоит левое соединение, запрос отрабатывает данные если проверять через консоль запросов, только с печатной формой проблемки. Как мне кажется, тут надо изменить что-то в этом куске:
// Выводим многострочную часть докмента
   ВыборкаСтрокТовары = Шапка.Товары.Выбрать();
   ОбластьМакета = Макет.ПолучитьОбласть("Строка");
   Пока ВыборкаСтрокТовары.Следующий() Цикл
        ОбластьМакета.Параметры.Заполнить(ВыборкаСтрокТовары);
      ОбластьМакета.Параметры.ТоварНаименование = ВыборкаСтрокТовары.ТоварНаименование;
      ОбластьМакета.Параметры.ДатаПриход = Формат(Шапка.ДатаПриход, "ДЛФ=Д");
        ТабДокумент.Вывести(ОбластьМакета);
   КонецЦикла;   

Оффлайн Вася Новенький

  • **
  • Сообщений: 53
  • РЕПУТАЦИЯ: 8
  • КПД: 15%
  • Регистрация: 2011-06-30
  • Сайт: 
  • Профессия: Программист 1С
у тебя должно быть Левое соединение инвентаризацию присоединяешь к поступлению, а ты наоборот.
ты к поступлению присоединяешь инвентаризацию.если такой порядок. тогда правое соединение.
Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
   |      ЛЕВОЕ СОЕДИНЕНИЕ Документ.ИнвентаризацияТоваровНаСкладе КАК ИнвентаризацияТоваровНаСкладе
   |      ПО (ИнвентаризацияТоваровНаСкладе.Товары.Номенклатура = ПоступлениеТоваровУслуг.Товары.Номенклатура)
   |ГДЕ

Оффлайн drapik

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 8.1
у тебя должно быть Левое соединение инвентаризацию присоединяешь к поступлению, а ты наоборот.
ты к поступлению присоединяешь инвентаризацию.если такой порядок. тогда правое соединение.
Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
   |      ЛЕВОЕ СОЕДИНЕНИЕ Документ.ИнвентаризацияТоваровНаСкладе КАК ИнвентаризацияТоваровНаСкладе
   |      ПО (ИнвентаризацияТоваровНаСкладе.Товары.Номенклатура = ПоступлениеТоваровУслуг.Товары.Номенклатура)
   |ГДЕ
Менял и левое и правое, один и тот же результат получается, все равно в печатной форме ДатаПриход у всех товаров из табличной части одно и то же значение

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Вобщем как-то так
ВЫБРАТЬ
ИнвентаризацияТоваровНаСкладе.Ссылка.Организация,
ИнвентаризацияТоваровНаСкладе.Ссылка.Дата,
ИнвентаризацияТоваровНаСкладе.Ссылка.ОтветственноеЛицо КАК ФизЛицо,
ИнвентаризацияТоваровНаСкладе.НомерСтроки КАК Номер,
ИнвентаризацияТоваровНаСкладе.Количество КАК Количество,
ИнвентаризацияТоваровНаСкладе.Номенклатура.НаименованиеПолное КАК ТоварНаименование,
ИнвентаризацияТоваровНаСкладе.Номенклатура.Код КАК ТоварКод,
ИнвентаризацияТоваровНаСкладе.Цена КАК Цена,
ПоступлениеТоваровУслуг.Ссылка.Дата КАК ДатаПриход
ИЗ
Документ.ИнвентаризацияТоваровНаСкладе.Товары КАК ИнвентаризацияТоваровНаСкладе
ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслуг
ПО (ИнвентаризацияТоваровНаСкладе.Номенклатура = ПоступлениеТоваровУслуг.Номенклатура)
ГДЕ
ИнвентаризацияТоваровНаСкладе.Ссылка = &ТекущийДокумент


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4302
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5559
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5898
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4386
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1985
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
55 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 274
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal