Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 18:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как блокировать диалоговое окно?  (Прочитано 2269 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн worker-good

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 8.1
Доброго времени суток!
В результате выполнения внешней обработки в конфигурации УПП, несколько раз выдается диалоговое сообщение: "Установить счета бух. и налогового учета в соответствии со значениями по умолчанию?" "Да", "Нет". Как изменить внешнюю обработку, чтобы диалоговое сообщение не выводилось, а все автоматически было "Да"?

Текст внешней обработки:
Процедура Сформировать() Экспорт
   Выборка = Документы.РеализацияТоваровУслуг.Выбрать(Дата1,КонецДня(Дата2));
   Пока Выборка.Следующий() Цикл
           Если Не Выборка.ПометкаУдаления и Выборка.Проведен Тогда
         Док = Выборка.ПолучитьОбъект();
         Сообщить(СокрЛП(Выборка.Ссылка));
         Док.ОтражатьВБухгалтерскомУчете=Истина;
         Док.ОтражатьВНалоговомУчете=Истина;
         Если Не СчетаУчетаВДокументах.ИнтерактивноПерезаполнитьСчетаУчета(Док, Истина, Новый Структура("Товары,ВозвратнаяТара,Услуги,СоставНабора"), Истина, Истина) Тогда
Сообщить(СокрЛП(Выборка.Ссылка) +" - Счета БУ и НУ не установлены!",СтатусСообщения.ОченьВажное);
         Иначе
             Док.Записать(РежимЗаписиДокумента.Проведение);
         КонецЕсли;
         
      КонецЕсли;
   КонецЦикла;
   Предупреждение("Обработка завершена!");
КонецПроцедуры
Заранее благодарен.


Оффлайн Victoriya

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-13
  • Сайт: 
  • Профессия: Программист 1С
Может как-то так: Ответ = КодВозвратаДиалога.Да;

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
   Выборка = Документы.РеализацияТоваровУслуг.Выбрать(Дата1,КонецДня(Дата2));
   Пока Выборка.Следующий() Цикл
           Если Не Выборка.ПометкаУдаления и Выборка.Проведен Тогда
         Док = Выборка.ПолучитьОбъект();
         Сообщить(СокрЛП(Выборка.Ссылка));
         Док.ОтражатьВБухгалтерскомУчете=Истина;
         Док.ОтражатьВНалоговомУчете=Истина;
         //Если Не СчетаУчетаВДокументах.ИнтерактивноПерезаполнитьСчетаУчета(Док, Истина, Новый Структура("Товары,ВозвратнаяТара,Услуги,СоставНабора"), Истина, Истина) Тогда
           //Сообщить(СокрЛП(Выборка.Ссылка) +" - Счета БУ и НУ не установлены!",СтатусСообщения.ОченьВажное);
         //Иначе
             Док.Записать(РежимЗаписиДокумента.Проведение);
         //КонецЕсли;
         
      КонецЕсли;
   КонецЦикла;
   Предупреждение("Обработка завершена!");
КонецПроцедуры

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
нет, я поторопился. Надо вызывать процедуру в модуле документа
ЗаполнитьСчетаУчетаВТабЧасти(Док.Товары, "Товары", Истина, Истина);
Это для табличной части товары.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Т.е. будет как-то так, не проверял.
Выборка = Документы.РеализацияТоваровУслуг.Выбрать(Дата1,КонецДня(Дата2));
   Пока Выборка.Следующий() Цикл
      Если Не Выборка.ПометкаУдаления и Выборка.Проведен Тогда
         Док = Выборка.ПолучитьОбъект();
         Сообщить(СокрЛП(Выборка.Ссылка));
         Док.ОтражатьВБухгалтерскомУчете=Истина;
         Док.ОтражатьВНалоговомУчете=Истина;
         Док.ЗаполнитьСчетаУчетаВТабЧасти(Док.Товары, "Товары", Истина, Истина);
         Док.Записать(РежимЗаписиДокумента.Проведение);         
      КонецЕсли;
   КонецЦикла;
   Предупреждение("Обработка завершена!");
КонецПроцедуры


Теги:
 

Как убрать окно "система готова к работе"

Автор stankevichpvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1609
Последний ответ 13 Апр 2015, 03:48
от Golickoff
Окно "Параметры учета" какое-то длинное и не видно кнопок применить и закрыть в ЗУП 2.5

Автор EvangelinaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1632
Последний ответ 13 Янв 2016, 13:07
от Evangelina
платформа 8.3 Окно выдает "Неверный формат хранилища данных" Помогите

Автор Виктор АлександровичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 853
Последний ответ 17 Мар 2016, 08:47
от Виктор Александрович
При открытии формы "Внутренние документы" окно уменьшается и съезжает влево

Автор davydovkРаздел Пользователям "1С - Предприятие 8"

Ответов: 12
Просмотров: 458
Последний ответ 22 Ноя 2017, 13:37
от davydovk
Переместить или растянуть окно сообщений в 1С-интерфейсе "Такси"

Автор robixРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1633
Последний ответ 25 Сен 2014, 16:55
от robix

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
140 Сообщений
AIFrame
70 Сообщений
ilyay ilyay
65 Сообщений
alex0402
51 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
BuhRust
31 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 395
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal