Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 04:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Взгляните на ошибку при обмене данными в 1С 8.1  (Прочитано 7090 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн avatar007911

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Бухгалтер
  1С:Предприятие 8.1 (8.1.13.41)
  "Розница для Украины", редакция 1.0.
  Разработка конфигурации: "ABBYY Ukraine", 2008  (1.0.2.1)
  Windows 7


Произвожу   обмен  данными  между  компьютерами.  Выгрузка  происходит
нормально,  а вот загрузить данные обмена компьютер не может. Пробовал
на двух компьютерах в разных направлениях - ошибка аналогичная.


Выполняемые действия: Загрузка данных
Тип обмена:  Обмен через файловый ресурс
Каталог обмена: J:\Obmen
Правила обмена: Правила обмена для выгрузки из "Розница для Украины, редакция 1.0 (1.0.1)" и загрузки в "Управление торговлей для Украины, редакция 2.3 (2.3.3)"



Служебные сообщения:

Начат обмен данными по настройке "Обмен с "555"" (14:23:45).
Начало загрузки:   08.07.2011 14:23:45
Ошибка при загрузке данных: {Обработка.ОбменДаннымиXML(11868)}: Тип не определен (СправочникСсылка.ХарактеристикиНоменклатуры)
Окончание загрузки: 08.07.2011 14:23:50
Ошибка при загрузке объектов. Было загружено: 0
Чтение данных из файла обмена завершено с ошибками!
Обмен данными по настройке "Обмен с "555"" завершен (14:23:50).



Отладка указывает на это место:

Процедура ЗагрузитьСоответствиеТиповДляОдногоТипа(ПравилаОбмена, СоответствиеТипа)
       
        Пока ПравилаОбмена.Прочитать() Цикл
               
                ИмяУзла = ПравилаОбмена.ЛокальноеИмя;
               
                Если (ПравилаОбмена.ТипУзла = одТипУзлаXML_КонецЭлемента) Тогда
                       
                    Прервать;
                       
                КонецЕсли;
               
                // прочитали начало элемента
                ПравилаОбмена.Прочитать();
               
                Если ПравилаОбмена.ТипУзла = одТипУзлаXML_НачалоЭлемента Тогда
                       
                        // это новый элемент
                        НовоеСоответствие = Новый Соответствие;
                        СоответствиеТипа.Вставить(ИмяУзла, НовоеСоответствие);
                       
                        ЗагрузитьОдинТипДанных(ПравилаОбмена, НовоеСоответствие, ПравилаОбмена.ЛокальноеИмя);                   
                       
                Иначе
 ===>                   СоответствиеТипа.Вставить(ИмяУзла, Тип(ПравилаОбмена.Значение));
                        ПравилаОбмена.Прочитать();
                КонецЕсли;     
               
        КонецЦикла;     
       
КонецПроцедуры


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Посмотрите отладчиком, какие типы в ошибочной строке, какая ошибка возникает после ее выполнения...
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн avatar007911

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Бухгалтер
подскажите как посмотреть?

вот еще скрины с ошибкой есть




Оффлайн avatar007911

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Бухгалтер
как здесь редактировать свои сообщения?

вот скрин покрупнее





Оффлайн mohock

  • ***
  • Сообщений: 170
  • РЕПУТАЦИЯ: 50
  • КПД: 29%
  • Регистрация: 2010-08-12
  • Сайт: 
  • Профессия: Программист 8.1
Если у тебя все раньше работало, а теперь нет, то очевидно было обновление конфигураций. Следует и правила обмена обновить. Я вижу у тебя две разные версии по рознице 1.0.1 - обмен и 1.0.2 - конфа. (Это если нет желания копаться в коде.) Если делаешь штатными средствами 1С обмен, то ты обязан держать в соответствии версии конфигураций и правил обмена.
Обычно, когда идет выгрузка м/у базами в большинстве случаев это перекидка из управленческого учета в регламентный. Практика показывает, когда дошло до такого обмена, то упр. база как правило доработана и поддерживать ее постоянно до свежего уровня ни у кого желания нет. Обновляют только регл. базы, и только потому, что в парламенте заседают весьма одаренные и творческие люди. Поэтому я обычно не пользую стандартный обмен, а пишу свой, который менее подвержен проблемам обмена.

Оффлайн avatar007911

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Бухгалтер
спасибо за ответ,
я впервые настраиваю обмен, ранее им не пользовался. попробую обновить до соответствия версий.

а как сделать без обновления? что править в коде получится объяснить мне в посте?

Оффлайн avatar007911

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Бухгалтер
Следует и правила обмена обновить.

как их обновлять? недогугливаю..

Оффлайн avatar007911

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-08
  • Сайт: 
  • Профессия: Бухгалтер
решил свою задачу другим способом.

вопрос закрыт. спасибо всем огромное за проявленное внимание.


Теги:
 

Обмен данными между 1С УТ (базовая) 8.2 редакция 10.3 и Розница (базовая) редакция 1.0

Автор Андрей ОлимпиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 5020
Последний ответ 17 Мар 2015, 20:16
от дфтын
Обмен РИБ, обмен данными между организациями

Автор Azamat FaizovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1234
Последний ответ 18 Сен 2014, 11:48
от Azamat Faizov
Обмен УТ 11 и БП 3.0 через универсальный обмен данными

Автор magnifico61Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 7096
Последний ответ 25 Дек 2014, 13:40
от cska-fanat-kz
обмен данными между 1с Розница и 1с Розница

Автор maksdemonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2517
Последний ответ 23 Мар 2015, 13:53
от cska-fanat-kz
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2760
Последний ответ 27 Май 2016, 15:19
от Олька Бякина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 128
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal