Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 03:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обработка реестр выписок, Бухгалтерия предприятия, редакция 2.0  (Прочитано 3901 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн forumlarin

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-31
  • Сайт: 
Как в обработке сделать чтоб обрабатывалось без переключателя, выводило все сразу

 

 

Изменинение я понимаю , что нужно поменять в этом блоке, а как не могу понять

 

 если ЭлементыФормы.Поступление.Значение            = 1 тогда
 ДокВыборка = Документы.ПоступлениеНаРасчетныйСчет.Выбрать(НачНДата, КонНДата);
 ОбластьМакета.Параметры.ВидДок   =  "Банковские выписки:  Приход в кассу"  ;
 иначе
 ДокВыборка = Документы.СписаниеСРасчетногоСчета.Выбрать(НачНДата, КонНДата);
 ОбластьМакета.Параметры.ВидДок   =  "Банковские выписки: Расход из кассы"  ;
 конецесли;

 

 

 

Весь код обработки:

 

Процедура КнопкаВыполнитьНажатие(Кнопка)

НачНДата   = НачалоДня(НачДата);
 КонНДата   = КонецДня(КонДата);


 ТабДокумент = Новый ТабличныйДокумент;
 ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Отчет";
 Макет       = ПолучитьМакет("Отчет");
 ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
 ОбластьСтроки = Макет.ПолучитьОбласть("Строка");

 ОбластьМакета.Параметры.НачНДата = НачНДата ;
 ОбластьМакета.Параметры.КонНДата = КонНДата ;
 ОбластьМакета.Параметры.Организация = Организация.НаименованиеСокращенное ;

 если ЭлементыФормы.Поступление.Значение            = 1 тогда
 ДокВыборка = Документы.ПоступлениеНаРасчетныйСчет.Выбрать(НачНДата, КонНДата);
 ОбластьМакета.Параметры.ВидДок   =  "Банковские выписки:  Приход в кассу"  ;
 иначе
 ДокВыборка = Документы.СписаниеСРасчетногоСчета.Выбрать(НачНДата, КонНДата);
 ОбластьМакета.Параметры.ВидДок   =  "Банковские выписки: Расход из кассы"  ;
 конецесли;


 ТабДокумент.Вывести(ОбластьМакета);

 Пока ДокВыборка.Следующий() Цикл
 Если ДокВыборка.Организация = Организация Тогда
 Док = ДокВыборка.ПолучитьОбъект();
 //Приход  в кассу ну и расход
 ОбластьСтроки.Параметры.Контрагент = Док.Контрагент            ;

 Если ПустаяСтрока(строка(Док.СчетУчетаРасчетовСКонтрагентом)) тогда
 строка =  Док.РасшифровкаПлатежа[0];

 КонецЕсли;


 ОбластьСтроки.Параметры.Дата = Док.Дата      ;
 ОбластьСтроки.Параметры.Номер=Док.Номер      ;
 ОбластьСтроки.Параметры.НазначениеПлатежа = Док.НазначениеПлатежа;
 ОбластьСтроки.Параметры.СуммаДокумента=Док.СуммаДокумента;
 ТабДокумент.Вывести(ОбластьСтроки);
 КонецЕсли;
 КонецЦикла;

 ТабДокумент.Показать("Отчет");
КонецПроцедуры


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Самописная обработка чтоли? Просто выводишь сначала все поступления, потом все списания. Вобще запросом лучше.

Оффлайн forumlarin

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-31
  • Сайт: 
Запрос написал а как его праувильно подставить

ВЫБРАТЬ
   ПоступлениеНаРасчетныйСчет.Номер,
   ПоступлениеНаРасчетныйСчет.Дата,
   ПоступлениеНаРасчетныйСчет.Контрагент,
   ПоступлениеНаРасчетныйСчет.СуммаДокумента,
   ПоступлениеНаРасчетныйСчет.НазначениеПлатежа,
   ПоступлениеНаРасчетныйСчет.Ссылка
ИЗ
   Документ.ПоступлениеНаРасчетныйСчет КАК ПоступлениеНаРасчетныйСчет

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
куда подставить? надо делать выборку результата запроса и ее обходить

Оффлайн forumlarin

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-31
  • Сайт: 
Вот таким образом

Процедура КнопкаВыполнитьНажатие(Кнопка)
   //НачНДата   = НачалоДня(НачДата);
   //КонНДата   = КонецДня(КонДата);
   
   ТабДокумент = Новый ТабличныйДокумент;
   ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Отчет";
   Макет       = ПолучитьМакет("Отчет");
   ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
   ОбластьСтроки = Макет.ПолучитьОбласть("Строка");
   
   ОбластьМакета.Параметры.НачНДата = НачДата ;
   ОбластьМакета.Параметры.КонНДата = КонДата ;
   ОбластьМакета.Параметры.Организация = Организация.НаименованиеСокращенное ;
   ТабДокумент.Вывести(ОбластьМакета);
   
   ДокВыборка = Документы.СписаниеСРасчетногоСчета.Выбрать(НачДата, КонДата);
   ОбластьМакета.Параметры.ВидДок   =  "Банковские выписки: Расход из кассы"  ;
   
   Запрос = Новый Запрос;
   Запрос.Текст =
       "ВЫБРАТЬ
        |    ПоступлениеНаРасчетныйСчет.Ссылка,
        |    ПоступлениеНаРасчетныйСчет.Организация
        |ИЗ
        |    Документ.ПоступлениеНаРасчетныйСчет КАК ПоступлениеНаРасчетныйСчет
        |ГДЕ
        |    ПоступлениеНаРасчетныйСчет.Проведен
        |    И ПоступлениеНаРасчетныйСчет.Дата МЕЖДУ &НачДата И &КонДата
        |    И ПоступлениеНаРасчетныйСчет.Организация = &Организация
        |
        |ОБЪЕДИНИТЬ ВСЕ
        |
        |ВЫБРАТЬ
        |    СписаниеСРасчетногоСчета.Ссылка,
        |    СписаниеСРасчетногоСчета.Организация
        |ИЗ
        |    Документ.СписаниеСРасчетногоСчета КАК СписаниеСРасчетногоСчета
        |ГДЕ
        |    СписаниеСРасчетногоСчета.Проведен
        |    И СписаниеСРасчетногоСчета.Дата МЕЖДУ &НачДата И &КонДата
        |    И СписаниеСРасчетногоСчета.Организация = &Организация";
   //Выбираете нужные поля(Контрагент, организация, сумма и т.п.
   Запрос.УстановитьПараметр("КонДата", КонецДня(КонДата));
   Запрос.УстановитьПараметр("НачДата", НачДата);//Дата всегда на 00:00:00
   Запрос.УстановитьПараметр("Организация", Организация);
   
   Результат = Запрос.Выполнить();
   ДокВыборка = Результат.Выбрать();
   
   Пока ДокВыборка.Следующий() Цикл
       //Если ДокВыборка.Организация = Организация Тогда //В запросе условие на Организацию.
           Док = ДокВыборка.Ссылка.ПолучитьОбъект();//Вместо _этого_, обратится к выборке, в которой есть суммы и прочее.
           //Приход  в кассу ну и расход
           ОбластьСтроки.Параметры.Контрагент = Док.Контрагент ;
           
           Если Док.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.ПустаяСсылка() тогда //Красивей;)
               строка =  Док.РасшифровкаПлатежа[0];
               //Вот вместо этого, надо сделать выборку из Расшифровки, итоги по ссылке, и вложеный цикл.
               //???.
           КонецЕсли;
           ОбластьСтроки.Параметры.Дата = Док.Дата ;
           ОбластьСтроки.Параметры.Номер=Док.Номер ;
           ОбластьСтроки.Параметры.НазначениеПлатежа = Док.НазначениеПлатежа;
           ОбластьСтроки.Параметры.СуммаДокумента=Док.СуммаДокумента;
           ТабДокумент.Вывести(ОбластьСтроки);
       //КонецЕсли;
   КонецЦикла;
   
   ТабДокумент.Показать("Отчет");
КонецПроцедуры



Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Вобще запутался. В чем именно проблема то?

Оффлайн forumlarin

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-31
  • Сайт: 
Сейчас уже не в чем , была просьба в помощи формирование запроса и так далее, сейчас ворос можно считать закрытым


Теги:
 

Обновление конфигурации "Аренда и управление недвижимостью для "1С:Бухгалтерия 8"" с 2.0 на 3.0

Автор Эльвина МуромцеваРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 224
Последний ответ 16 Ноя 2017, 14:26
от Геннадий ОбьГЭС
Как перенести данные из 7.7 типовая УСН 1.3 в 1С 8 типовая бухгалтерия

Автор Александр бухгалтерРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4837
Последний ответ 13 Фев 2010, 07:58
от Александр бухгалтер
Обмен данными Зарплата 8 (бюджет)-Бухгалтерия 8 (бюджет)

Автор VanillaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3226
Последний ответ 14 Дек 2009, 11:16
от Vanilla
Модуль учета спецодежды "Бухгалтерия 2.0"

Автор avtobuhРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 10013
Последний ответ 22 Дек 2011, 07:40
от Slin
О конфигурации "Бухгалтерия Государственного учреждения"

Автор КотоваРаздел Закрытые темы

Ответов: 12
Просмотров: 10770
Последний ответ 09 Мар 2012, 09:53
от Котова

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 173
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal