Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 01:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите плиз..  (Прочитано 1663 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sus

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-04
  • Сайт: 
  • Профессия: Ученик 1С
Только начал работать с 1С8.2, подскажите есть три склада, надо сделать отчет о движении товаров на складе, как сделать чтоб выводило товар только по указанному складу, а у меня выводит во всех случаях по всем....


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Re: Помогите плиз..
« Ответ #1: 06 Июл 2011, 11:33 »
А где Ваш пример кода? Какое усилие сделали Вы?

Оффлайн Sus

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-07-04
  • Сайт: 
  • Профессия: Ученик 1С
Re: Помогите плиз..
« Ответ #2: 06 Июл 2011, 12:03 »
Процедура КнопкаСформироватьНажатие(Кнопка)
      
   Запрос = Новый Запрос;

   Запрос.Текст =
      "ВЫБРАТЬ
      |   ХозрасчетныйОстаткиИОбороты.Субконто1.Код КАК Код,
      |   ХозрасчетныйОстаткиИОбороты.Субконто1.Наименование КАК Наименование,
      |   ХозрасчетныйОстаткиИОбороты.Субконто1.БазоваяЕдиницаИзмерения КАК ЕдИзм,
      |   ХозрасчетныйОстаткиИОбороты.Субконто3.Родитель.Наименование КАК Склад,
      |   ХозрасчетныйОстаткиИОбороты.КоличествоНачальныйОстаток КАК КолНачОст,
      |   ХозрасчетныйОстаткиИОбороты.СуммаНачальныйОстаток КАК СуммНачОст,
      |   ХозрасчетныйОстаткиИОбороты.КоличествоОборотДт КАК КолПр,
      |   ХозрасчетныйОстаткиИОбороты.СуммаОборотДт КАК СуммПр,
      |   ХозрасчетныйОстаткиИОбороты.КоличествоОборотКт КАК КолРасх,
      |   ХозрасчетныйОстаткиИОбороты.СуммаОборотКт КАК СуммРасх,
      |   ХозрасчетныйОстаткиИОбороты.КоличествоКонечныйОстаток КАК КолКонОст,
      |   ХозрасчетныйОстаткиИОбороты.СуммаКонечныйОстаток КАК СуммКонОст,
      |   Хозрасчетный.Код КАК КодСчет,
      |   ХозрасчетныйОстаткиИОбороты.Субконто1.Родитель.Код КАК КодРод,
      |   ХозрасчетныйОстаткиИОбороты.Субконто1.Родитель.Наименование КАК НаименованиеРод
      |ИЗ
      |   РегистрБухгалтерии.Хозрасчетный.ОстаткиИОбороты(&НачалоПериода, &КонецПериода, Период, ДвиженияИГраницыПериода, , , ) КАК ХозрасчетныйОстаткиИОбороты
      |      ЛЕВОЕ СОЕДИНЕНИЕ ПланСчетов.Хозрасчетный КАК Хозрасчетный
      |      ПО ХозрасчетныйОстаткиИОбороты.Счет = Хозрасчетный.Ссылка
      |      ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Номенклатура КАК Номенклатура
      |      ПО ХозрасчетныйОстаткиИОбороты.Субконто2 = Номенклатура.Ссылка
      |         И ХозрасчетныйОстаткиИОбороты.Субконто3 = Номенклатура.Ссылка
      |         И ХозрасчетныйОстаткиИОбороты.Субконто1 = Номенклатура.Ссылка
      |УПОРЯДОЧИТЬ ПО
      |   Склад
      |ИТОГИ ПО
      |   НаименованиеРод";
   Запрос.УстановитьПараметр("КонецПериода", КонецПериода);
   Запрос.УстановитьПараметр("НачалоПериода", НачалоПериода);

   Результат = Запрос.Выполнить();
   
               
   Выборка = Запрос.Выполнить().Выбрать();
   ЭлементыФормы.Результат.Очистить();
      
   ТабДок = ЭлементыФормы.Результат;
   Макет = ПолучитьМакет("Макет");
   облИмя = Макет.ПолучитьОбласть("Имя");
   облСтрПер = Макет.ПолучитьОбласть("СтрПер");
   облШапка = Макет.ПолучитьОбласть("Шапка");
   облДетали = Макет.ПолучитьОбласть("Детали");   
   облГруппа = Макет.ПолучитьОбласть("Группа");
   облГруппа2 = Макет.ПолучитьОбласть("Группа2");
   
   ТабДок.Вывести(облИмя);
   
   СК = Формат(Склад);
   облГруппа2.Параметры.СК = СК;
   ТабДок.Вывести(облГруппа2);
   
      
   СтрокаПериода = "с  " + Формат(НачалоПериода, "ДФ = ""дд.ММ.гггг""; ДП = ""-""")
         + "  по  "      + Формат(КонецПериода, "ДФ = ""дд.ММ.гггг""; ДП = ""-""");
      
   облСтрПер.Параметры.СтрокаПериода = СтрокаПериода;
   ТабДок.Вывести(облСтрПер);
   
   ТабДок.Вывести(облШапка);
   
   
   Пока Выборка.Следующий() Цикл
      Если Выборка.ЕдИзм = NULL Тогда
         облГруппа.Параметры.Заполнить(Выборка); табДок.Вывести(облГруппа);
      Иначе
         облДетали.Параметры.Заполнить(Выборка); табДок.Вывести(облДетали);
      КонецЕсли;
             
      
   КонецЦикла;
   
      
   ТабДок.Показать();
      
КонецПроцедуры

 Процедура Кнопка1Нажатие(Элемент)
   
   УстановкаПериода(НачалоПериода, КонецПериода);
   
КонецПроцедуры

 Процедура УстановкаПериода(ДатаНач, ДатаКон)
   
   НП = Новый НастройкаПериода;
   НП.ВариантНастройки = ВариантНастройкиПериода.Период;
   
   НП.УстановитьПериод(НачалоДня(ДатаНач), ?(ДатаКон = '00010101', ДатаКон, КонецДня(ДатаКон)));

   Если НП.Редактировать() Тогда

      НачалоПериода = НП.ПолучитьДатуНачала();
      КонецПериода = НП.ПолучитьДатуОкончания();
      
   КонецЕсли;
КонецПроцедуры

Оффлайн cannabis_86

  • ***
  • Сообщений: 168
  • РЕПУТАЦИЯ: 19
  • КПД: 11%
  • Регистрация: 2010-08-26
  • Сайт: 
Re: Помогите плиз..
« Ответ #3: 06 Июл 2011, 12:18 »
Чесно говоря, очень мне не нравится ваш запрос. Слишком замудрен). Анализируйте 41 счет(+10 счет, если используете). И условие ставьте по Субконто2="Тот склад, который вам нужен"


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4292
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5551
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5888
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4366
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1978
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 190
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal